Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed 12.04 LTS but surprisingly not able to login as root. I have unlock and set the password for root but while login i can not see 'other' option in GUI login where i can put root id and password.

please help me.

share|improve this question
    
@JorgeCastro, he's trying access root using the login interface. –  FRD Apr 27 '12 at 16:46
    
See askubuntu.com/q/16178/6161 about why this is a REALLY bad idea. –  David Oneill Apr 27 '12 at 16:50
add comment

6 Answers

Caveat: Don't do this unless you have a good reason

I store my home directory in lvm and occasionally need to unmount it to perform maintenance. It's much more convenient to login as root in those circumstances, as I can look up documentation online and browse the web while waiting for fsck.

By default, Ubuntu's greeter LightDM no longer supports logging in with an arbitrary username as it did in the past.

Default Config

But this is still Linux, and we can configure this. Edit /etc/lightdm/lightdm.conf with root privileges and add this line:

[SeatDefaults]
greeter-show-manual-login=true

Reboot, and you can now login as any user by username including root.

Altered Config

share|improve this answer
add comment

You can also try opening the terminal (ctrl + T) and entering the following:

sudo su

type your password, and you should then have root privileges. Hope this helps! :)

Note: Try sudo nautilus also, so you can explore folders and file in the GUI.

share|improve this answer
    
i want to login as root in GUI. –  Tapas Apr 27 '12 at 16:46
add comment

To do that you should try writing these on the terminal window (ctrl+T):

sudo su
passwd

For the first command you will probably have to type in your password. The second will set your root password to whatever you enter.

share|improve this answer
    
not this option.. i want to login as root –  Tapas Apr 27 '12 at 16:47
add comment

As far as I know you can't login as root at the GUI login screen and it would be a bad idea anyway. Juan's answer is correct - you can launch a terminal and sudo su to root user (if you are in the sudoers group) and then launch a program which uses a GUI if you wish.

share|improve this answer
    
this option was available till 11.10..is it not available in 12.04? –  Tapas Apr 27 '12 at 16:50
    
I used 11.10 for a long time and never realized that was possible. I see from this site: [blog.sudobits.com/2011/09/05/… that it was. I really don't want to test that on my current system it seems like a terrible security risk. –  in8sworld May 1 '12 at 15:54
add comment

This is not possible (without a lot of work manually overriding stuff) because it is pretty much always a bad idea.

In this question, there is a good discussion about the many things that can go wrong if you log in as root. Many things won't work at all. Other things won't work as expected. If you do anything wrong, you could destroy all the data on your computer. It makes your computer more vulnerable than windows to malicious attacks.

In all cases I've ever heard of, when a person is asking how to log in as root, they are trying to log in as root to accomplish something that could be better done without logging in as root.

As such, I recommend editing the question to ask how do best accomplish whatever you are actually trying to accomplish. We'd be happy to help you get to your goals :)

share|improve this answer
    
thanks...well while installation i created 3 partition /,/home,/swap...now after installation i can not see /home...i can see home folder under / but cant see /home drive or directory. –  Tapas Apr 27 '12 at 18:06
    
@Tapas If you have just recently installed, the easiest way to fix this would be to simply install from scratch. However, if you do already have files you want to save, boot from the CD (or DVD or flash drive) you used for the installation. From there, you should be able to fix whatever is broken. (If you need more help fixing the partition, I'd recommend putting in a new question - I don't know enough to help with that) –  David Oneill Apr 27 '12 at 18:39
    
Not everyone who wants to do this is a noob. My /home is located on an lvm partition, and when I unmount it to do maintenance I would login as root so I could use tabbed terminals, and pull up documentation in a browser. –  Adam Lassek May 3 '12 at 2:14
add comment

First:

To actually enable root logins, first you have to set a password for the root account, and then unlock the locked root account. If you don't set a password for the root account the passwd command will return

`passwd: Unlocking the password would result in a passwordless account`

So, first execute in a terminal

sudo passwd root

you will prompted for a new Unix password. Write it twice(second for confirmation).

Then execute

sudo passwd -u root

to unlock the account. This should return

passwd: password expiry information changed

Reverting back

If you want to disable root account in Ubuntu you need to lock the root account by using the following command sudo passwd -l root

Second:

Open the terminal:and type

gksudo gedit /etc/ect/lightdm/lightdm.config

(Orignal ) this it what it should already look like:

[SeatDefaults] 
greeter-session=unity-greeter          
user-session=unity                         
greeter-show-manual-login=true 
greeter-show-manual-login=true 

(What you need to replace the orignal with)

[SeatDefaults] 
autologin-user=<YOUR USER> 
autologin-user-timeout=0 
user-session=ubuntu 
greeter-session=unity-greeter

You will auto-log into root

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.