Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated my system to Ubuntu 12.04. It was running great. I decide to download Ubuntu Tweak and do some housecleaning. After reboot when I try to login nothing happens except a "Logging in" message. This happens with all options including Gnome 3.4.

What should I do?

share|improve this question
    
What do you mean with "and do some housecleaning"? Can you be more specific about what you did? –  dadexix86 Apr 27 '12 at 16:16
    
I cleaned my system using the Janitor option, and did some other edits offered (none of which I remember at the moment). –  chazdg Apr 27 '12 at 16:18

3 Answers 3

up vote 1 down vote accepted

It happened to me too. use gdm to replace lightdm

  1. go to a text terminal using alt-ctrl-F1
  2. Stop LightDM with sudo stop lightdm
  3. Start GDM with sudo start gdm
  4. Run sudo dpkg-reconfigure lightdm to set the default display manager for gdm
  5. Edit /etc/X11/default-display-manager and set it to /usr/sbin/gdm if you can't run the above
  6. Restart your computer and login.
share|improve this answer

I found that when I set: Ubuntu Tweak, Login Settings, "Set the same background as the current desktop background" (I also have "Draw Grid" ON, but that was ON before), the login screen then actually does not show my current background but the purple default - however, when before it took me 2-4 cycles of shutdown/login to actually log in, with the changes I was able to login 5x in a row without problems.

Wonder whether this will work for you as well.

share|improve this answer
    
There is a bug open for this: bugs.launchpad.net/unity-greeter/+bug/986967 . Looks like the patch does work already, will wait until it is included in normal SW-Update, since I have a workaround... –  cbourbou May 8 '12 at 13:41

In my own question thread After upgrade to 12.04, hanging in login screen , Roberto says not to hit ENTER but to press the > icon (I assume he doesn't mean the > key on the keyboard). Can't test it since I've stored my notebook in the office, going an a 1 week vacation...

Hope it works for you....l

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.