Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having difficulty finding a fix for my slow boot. Along with Ubuntu taking long time to boot it also will sometimes not load and after restart and on boot. I am running Ubuntu 12.04 LTS. 64-bit. Dell XPS M1730. I am extremely new to Linux so there may be an easy fix for this. I may end up having to reinstall Ubuntu. I was trying to avoid that.

[ 3.374844] input: Broadcom Corp as /devices/pci0000:00/0000:00:1a.0/usb3/3-2/3-2.3/3-2.3:1.0/input/input9

[ 3.374936] generic-usb 0003:0A5C:4503.0005: input,hidraw4: USB HID v1.11 Mouse [Broadcom Corp] on usb-0000:00:1a.0-2.3/input0

[ 7.977885] EXT4-fs (sda1): INFO: recovery required on readonly filesystem

[ 7.977888] EXT4-fs (sda1): write access will be enabled during recovery

[ 9.336852] EXT4-fs (sda1): recovery complete

[ 9.337253] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)

[ 19.007787] ADDRCONF(NETDEV_UP): eth0: link is not ready

[ 19.093301] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro

[ 19.108582] udevd[498]: starting version 175

I'm getting anywhere from 50 to 200 seconds of boot time. On average im getting more errors like:ADDRCONF(NETDEV_UP): eth0: link is not ready I have gotten up to 4 of these errors in one boot. I am assuming once I fix one error all of them should clear up.

I have searched forums, but all I see is temporary fixes and hardware issues. I have tried shutting off my wireless, disconnecting all USB drives, and disconnecting my network cable all have been without success or change in boot time. I have seen alot of fourms with people who are getting the same error and they have a long shutdown time. My shutdown time is where it should be takes about 10 seconds (max) to shutdown.

Any help is appreciated.

share|improve this question
1  
Install bootchart (it is in the repos; more info here: bootchart.org ) and when you have a slow boot check the timestamps on the image bootchart made. Also have a look here at htorque's comment: askubuntu.com/questions/48253/whats-wrong-with-my-bootchart –  Rinzwind Apr 30 '12 at 14:17

1 Answer 1

If you don't use ethernet you can add it to blacklist. I reduced my boot time from 140 seconds to 70 seconds(still too much, searching for other reasons).

Here's an instruction how you can do it.

share|improve this answer
    
Please elaborate on the question and not just provide the link. Thanks –  Amith KK Oct 13 '12 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.