Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Alt+Tab is not switching between windows. While on a terminal, When I tried Alt+Tab, It only showed the effect of Tab which was : Display all 1784 possibilities? (y or n)

My Alt is working fine as to get the panel menu, I have to do Alt+right-click.

Why isn't Alt+Tab working?

I'm using Gnome classic and not unity.

share|improve this question

closed as off topic by jokerdino, Jacob Johan Edwards, fossfreedom May 1 '12 at 11:46

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you try Ctrl + Alt + Tab –  wojox Apr 27 '12 at 14:55
    
Yes I did. But alas with the same result as above. –  harisibrahimkv Apr 27 '12 at 15:02
    
Is this Unity 3D? –  wojox Apr 27 '12 at 15:06
1  
@harisibrahimkv: as soon as you are using a different desktop environment, you've got what is quite definitely a non-standard arrangement. –  Chris Morgan Apr 27 '12 at 15:10
1  
I guess you can close it as my problem has been solved and as for others it has been filed as a bug report. Thank you. –  harisibrahimkv May 1 '12 at 8:46

3 Answers 3

up vote 6 down vote accepted

Well, just to finalize the answer, a reboot has done the trick for me after doing the following:

I went to system-settings -> keyboard -> shortcuts and almost all of them were disabled. I assigned "Alt+Tab" to "Switch applications". Then even though the problem specified in one of the comments above persisted, a reboot has solved the problem and I'm able to switch between windows without any problem.

Edit: Sometimes you have to reboot multiple times.

share|improve this answer
    
That worked for me as well, thanks! –  Lukas Stejskal Jul 4 '12 at 16:14

I'm also using Gnome Classic (with effects or without them). I have reported the bug about Alt+Tab, but Sebastien Bacher said that it is not a bug. I found that it's duplicate of 971051. Let's make these bugs heater!

As temporary solution we can install CompizConfig Settings Manager and select 'Application Switcher' or 'Static Application Switcher' from Window Management group.

share|improve this answer

I use Super + W and select from current open programs. not the best solution to this issue but it helps.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.