Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Three ubuntu based systems installed on external drive; boot from external drive. Upgrade Kubuntu system from 11.10 to 12.04 wiped out grub. Attempt to boot from external drive results in Grub reporting no partition found three times. Grub reinstall attempts on my part result in failure with 'cannot stat aufs' message. Request assistance to restore Grub.

share|improve this question
add comment

2 Answers 2

Solved - For info - https://help.ubuntu.com/community/Boot-Repair

Repaired the above case for the three installed systems on one external hard drive; and another case where after a clean install of Ub 12.04 (on a different external drive) the intitial result on reboot after completing the install resulted in grub reporting "error: no such partition".

share|improve this answer
add comment

I had the SAME problem. 4 times Grub was wiped out. I thought about it, checked the forums and no one had an answer. Then I remembered I had trouble installing 11.04 when I selected "Download Updates" during the installation. I read on a forum not to select the updates during the install and do the updates in terminal after the installation completed. So the 5th time I installed the upgrade from Terminal. Sudo "do-release-upgrade -d". Worked perfectly with no issues. I was prompted where to install grub and the installation confirmed it had found ALL of the operating systems I had installed and added them to the list. I ran all the applicantions I have installed with no issues what so ever and 12.04 seems faster. Good luck...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.