Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I did fresh installs of Ubuntu 12.04 on all my computers yesterday and one of them just doesn't seem to like 12.04. Let's start with the symptoms:

  1. I initially tried installing through a USB flash with the desktop amd64 version. Since it had worked on all other (5) computers, I believe the USB flash drive was ok. However the computer seemed to be stuck after the Ubuntu GUI came up (bar on the top, pinkish background) but before the screen prompting to Try or Install. When the screen came up, the mouse was moving exceptionally slowly, i.e. it responded 2-3 seconds after I had moved it. After a few minutes, I could move the mouse with normal speed, but could not click anything. The Try/Install window never came up. The same thing had happened a few days ago when I had tried to install Ubuntu 12.04 Beta 2 on the same computer, but when the Try/Install screen kept failing to come up, I gave up.

  2. I assumed it was a problem with the desktop installer, so I tried the alternative installer, which worked fine. But then, the same (or possibly a similar) problem appears on the login screen: the mouse moves very slowly in the first few minutes, then it moves normally, I cannot click anything (for example the buttons on the top right), and I cannot type in my password to login or select the guest session.

So I am stuck at the login screen. I did not encounter any problems on my other computers, so here are some specs of this one:

CPU: Intel i7 980x extreme edition, Motherboard: Asus Rampage III extreme, RAM: 6GB, GPUs: 2x NVidia GTX 580 in SLI, HDD: Western digital 1TB green power (20GB for root (/), 6GB for swap, all the rest for /home)

I should also note that this PC ran 11.10 flawlessly until yesterday, when I attempted to install 12.04. I tried installing 11.10 after I failed with 12.04 and it worked again, so its definitely something related to 12.04.

Unfortunately, due to the nature of the problem, I don't know how to provide any logs, but if there is some way let me know.

share|improve this question
Bug posted here: – belacqua May 27 '12 at 23:29
up vote 6 down vote accepted

I had the same problem with Nvidia GITX 580 on 12.04 64bit. Here is the solution:

  1. At the lightdm login page, press Ctrl+Alt+F1 to switch to the console (text mode).
  2. Login using your credentials.
  3. Run sudo apt-get update; sudo apt-get upgrade;
  4. Install nvidia driver using this command: sudo apt-get install nvidia-current
  5. Reboot.
  6. Now you should be able to use your keyboard and login in lightdm.
share|improve this answer
This worked, thanks. I need to point out that: You NEED to make sudo apt-get upgrade, or else lightdm won't autostart. – Alexander Karatarakis Apr 28 '12 at 10:14
Another addition: After the restart, lightdm won't autostart. Login through the console and execute: 'sudo lightdm start'. From the next boot, lightdm will autostart normally. – Alexander Karatarakis May 9 '12 at 18:28
Still does not always default to lightdm :/. – Alexander Karatarakis May 11 '12 at 11:23

The problem, appears to be lightdm. I uninstalled it, installed gdm. Now it works. Make sure and apt-get update.

share|improve this answer
Confirming that this works too. – Alexander Karatarakis May 19 '12 at 21:52

I'm experiencing the same problem as well here. Booting the installation CD works, to the point where the purple background displays and the bar at the top loads. As soon as the "Install" Welcome screen appears there is a blank white box in the middle (where the Try/Install Ubuntu normally is displayed). That is all I ever get.

System Info:

CPU: Intel i7 2600K

GPU: Nvidia GTX 590

Mem: 16GB DDR3 (1333mhz)

Mobo: Asus P8Z68-V Pro

Thought it was my bios at first, but seemingly disproved it after resetting. Is there a way to get past this, would really like to try Ubuntu. Hopefully its not a bug that will take forever to fix.


Was able to solve this problem!

Just as the CD is booting (I.e. the purple background first appears) press F6. You will get a few options (try ubuntu, install ubuntu, etc). You will also have the ability to press F6 again to select booting options. Select "nomodeset" and then proceed to "install ubuntu". It will work no problem! (at least it did for me)

share|improve this answer
This solved the installation phase part of my problem :). I was able to install with desktop-amd64 without having to resort to alternative-amd64, which is much slower. – Alexander Karatarakis Apr 28 '12 at 10:17
Note for people possibly encountering what I did: F6 toggles the Ubuntu logo or console text during Ubuntu boot up. Noting it here just in case you get text during bootup after installation. – Alexander Karatarakis Apr 28 '12 at 10:37

I had this same problem on my VirtualBox setup. Seems that if the system can not login using 3d acceleration, it simply falls back to the login prompt with no other warnings. I found I was able to log in if I changed to 2d prompt, install the VirtualBox drivers, rebooted and the system worked as expected. So it looks like if you need a 3rd party video driver, you must start in 2d and install the driver first before the system will boot properly.

share|improve this answer
Check the accepted answer :) – Alexander Karatarakis Apr 28 '12 at 10:21

protected by Community May 19 '12 at 22:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.