Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an OpenVZ VPS, and am trying to upgrade Ubuntu Server from 11.10 to 12.04. But the upgrade aborts half-way with this error:

WARNING: this version of the GNU libc requires kernel version
2.6.24 or later. Please upgrade your kernel before installing glibc.

The installation of a 2.6 kernel _could_ ask you to install a new
libc first, this is NOT a bug, and should *NOT* be reported. 
In that case, please add lenny sources to your /etc/apt/sources.list
and run:   apt-get install -t lenny linux-image-2.6 Then reboot into 
this new kernel, and proceed with your upgrade 

dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu10_amd64.deb (--unpack):  subprocess new pre-installation script returned error exit status 1 No apport report written because MaxReports is reached already

Could not install the upgrades 

The upgrade has aborted. Your system could be in an unusable
state. A  recovery will run now (dpkg --configure -a). 

Upgrade complete 

The upgrade has completed but there were errors during the upgrade  process. 

To continue please press [ENTER]
=== Command detached from window (Thu Apr 26 10:31:16 2012) ===
=== Command terminated with exit status 1 (Thu Apr 26 10:31:16 2012) ===
share|improve this question
1  
Please could you post more information about what you did to initiate the upgrade? Simply copying and pasting the text from a terminal is not sufficient to constitute a question. You need to explain what you did as well. –  SabreWolfy Apr 29 '12 at 9:45
1  
The error message above suggests that an earlier version of the kernel s installed. If you still have a working 11.10 system, can you post the output of "uname -a" and "lsb-release -a"? –  SabreWolfy Apr 30 '12 at 22:30
    
It's a VPS. I've subsequently reimaged it with 11.04 (the most recent image available to me), and upgraded it to 11.10. When I do the upgrade from 11.10 to 12.04, it fails - but the output of lsb-release -a indicates it's 12.04 - even though it's otherwise dead in the water. –  Chris May 1 '12 at 20:24
    
That's very frustrating. I successfully upgraded a 11.10 server to 12.04 (over an ssh connection), as have others I'm sure. I wonder if it's related to the VPS layer. –  SabreWolfy May 2 '12 at 16:39
    
@Chris please select the answer that helped you or give further details –  dvb May 4 '12 at 11:29
show 2 more comments

closed as too localized by fossfreedom Dec 21 '12 at 9:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

Did you ensure that the machine is fully updated before starting the upgrade process? Run the following first:

sudo apt-get update && sudo apt-get dist-upgrade

to be quite sure that everything is updated for 11.10 first. After that has completed successfully, run:

sudo do-release-upgrade

share|improve this answer
    
Yes, I had already ensured that 11.10 was completely updated prior to the upgrade to 12.04. Thank you anyway. –  Chris Apr 30 '12 at 20:23
    
I've added a comment to your question requesting more information. –  SabreWolfy Apr 30 '12 at 22:30
add comment

I did have an issue kind of similar with the kernel, try updating this way instead it worked fine for me. ubuntu 12.04 update info

share|improve this answer
    
Unfortunately, I've already tried all that. None of it worked. Thank you anyway. –  Chris Apr 30 '12 at 20:21
add comment

I see the comments show you are running Ubuntu Server on a VPS (aka VDS)? Can you post the output of uname -r?

You are getting the error because your provider is running an old OpenVZ Linux kernel (usually 2.6.18); as the message says, the default libc included with Precise requires 2.6.24 or above.

Please see my answer here for full details, but the gist is that I've set up a PPA with recompiled libc to work on older (at least 2.6.18) kernels, and that should solve your problem. Please try adding ppa:izx/ovz-libc, updating, and then retrying the upgrade. Specifically:

apt-add-repository ppa:izx/ovz-libc
apt-get update
apt-get -f install
do-release-upgrade

should probably do it. Recommend answering NO to all "update config?" questions.

Let me know how it goes -- I know the recompiled libc works perfectly for folks starting off with 12.04 or who have upgraded to it with the help of their host.

share|improve this answer
1  
Failed to fetch ppa.launchpad.net/izx/ovz-libc/ubuntu/dists/natty/main/… 404 Not Found :( –  user55044 Nov 5 '12 at 12:20
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.