Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In 12.04 (and prior, I believe), + (like Windows+1) will switch to the first app in the launchbar. Can I disable this somewhere? I like to use Super+Number to switch between workspaces.

share|improve this question
    
These shortcuts are hardcoded into Unity in Ubuntu 12.04, so without editing the source code and recompiling, this won't be possible. –  jasmines Jun 20 '12 at 10:21
add comment

3 Answers

You can change the unity keybindings using compizconfig-settings-manager. Go to the Ubuntu Unity Plugin and change the "Key to show the launcher" option.

Bear in mind that changing some options with compizconfig-settings-manager can break unity.

share|improve this answer
    
These shortcuts are hardcoded into Unity in Ubuntu 12.04, so without editing the source code and recompiling, this won't be possible. –  jasmines Jun 20 '12 at 11:13
add comment

Isn't that keyboard shortcut overridden by the Keyboard Shortcuts configuration?

Try going to System Settings -> Keyboard -> Shortcuts.

Check if there is a key already assigned (Switch to workspace 1, 2, etc.), to do what you wish, and change it.

share|improve this answer
    
These shortcuts are hardcoded into Unity in Ubuntu 12.04, so without editing the source code and recompiling, this won't be possible. –  jasmines Jun 20 '12 at 11:13
add comment

Change keybinding "Key to show the launcher" with compizconfig-settings-manager is bad, dirty and cheap solution. But, changing Super hotkey to Shift+Super is satisfactory for me. Now I use Super+Number to navigate between workspaces and Shift+Super+Number to navigate between application from panel. Thanks to all.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.