Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble getting Unity to run properly. I can play HoN but if I log in with Unity the system becomes slow and laggy.I think this system had earlier versions of Unity running before but now it does not. One day in version 11.04 it started freezing so I upgraded to 12.04 to see if the issue would disappear by itself but it didn't.

I'm using the drivers included in Additional Drivers, "NVIDIA accelerated graphics driver(version current) [Recommended]".

I also got this error message when I logged in with Unity 2D that Window Decoration has stopped working or something. It also said something about Compiz.

How do I fix this?

share|improve this question

closed as off topic by fossfreedom May 21 '12 at 22:01

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are you using 64bit edition from Ubuntu 12.04? –  Steven Peter Beer Apr 27 '12 at 15:03
    
Exactly the same issue here. I'm using a Nvidia GeForce 8800 GTS and it worked perfectly in earlier versions of Ubuntu. The system was running on 11.04 (32Bit edition) as unity began to be extremly slow and unusable directly after startup, so I upgraded to 12.04 but still have the same issue. Unity 2D is still working, altough it crashes some times. I'm using the same additional driver as LeMisanthrope. I think the problem has something to do with compiz, as soon as I kill compiz, the system "works". –  user57333 Apr 27 '12 at 16:42
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  fossfreedom May 21 '12 at 22:01

1 Answer 1

up vote 1 down vote accepted

You need disable flipping in OpenGl Settings:

Settings screen

share|improve this answer
    
Sorry for long delay, Unity 2D worked so well that I forgot about this problem. Disabling Flipping does the trick. I am now logged in to regular Unity although I don't notice any difference. –  LeMisanthrope Jun 1 '12 at 17:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.