Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While experimenting with sending virtual keystrokes, things got seriously hung up! I powered off, When the system restarted all window decoration was missing, and all fancy compiz graphics was missing.

I ran metacity --replace. That brought back the window decoration, but still no compiz. I ran compiz --replace, that brought back compiz functionality, but this time, no window decoration.

How can I get Compiz and Metacity back together again?

share|improve this question
up vote 11 down vote accepted

Compiz and Metacity are both window managers. You cannot use two different window managers at the same time. However, windows' decoration is done by a window decorator, not a window manager. You can use, e.g., either gtk-window-decorator (which can match your previous MetaCity themes), or Beryl's own emerald window decorator, which was made to work with Compiz, and has lots of nice themes.

Whatever you choose, be sure to check the settings for Compiz's Window Decorator plugin. (Run CompizConfig Settings Manager or ccsm and enable that plugin, and choose either gtk-window-decorator or emerald for the command; perhaps adding --replace if it helps.)

share|improve this answer
I'm still tying to figure out what's going on here... In Compiz,"Window Decoration" I have /usr/bin/compiz-decorator --replace(the default doesn't have the "--replace")... I now get the window decoraton.. but I haven't actuall changed anything (that I know of), and now my Panel has gone missing! .... I'll reboot .... – Peter.O Nov 11 '10 at 6:13
I'm finally back from many reboots.. Some of the unusual behaviour comes from issueing commands in this form metacity --replace/` compiz --replace. This causes semi-waiting states in the terminal which, for metacity, gives **no** decoration, until I repeat "metacity --replace" consecutively... However it works **every time** with (metacity --replace&)/(compiz --replace&). Also, issuing the no-bracket, no-&` form via Alt-F2 works too.. And I now understand a lot better, how these items fit into the scheme of things.. eg: (emerald --replace&) when Compiz is the manager :) Thanks – Peter.O Nov 11 '10 at 7:35

Compiz and Metacity are both compositing window managers. That can't coexist--you can only have one or the other.

Really your problem is that you're missing window decorations with compiz. Can you post the output of compiz --replace? I don't know enough to help you here, but maybe someone else does. Also explain exactly what you were doing when the decorations disappeared.

share|improve this answer
Aha!.. Does that mean that Compiz is more than just a "window manager", and that when Metacity is the mangager, the fancy Compiz graphics actually have nothing to do with Compiz's "window management" functions? ..... Re the crash: I ran a command similar to this echo -n "KeyStrPress a KeyStrRelease a" | xmacroplay -d 1 :0.0 but with Control and Alt keys, and it seemed to leave them in a pressed state.. Attempts to close the terminal via the mouse locked things up &>/dev/null – Peter.O Nov 11 '10 at 5:25

I face the problem often. Try installing the compiz fusion icon -package name 'fusion-icon'. Once installed it will show up in your system tray. Trying playing around with the settings. Indirect rendering tends to solve this problem sometimes.

share|improve this answer

I had the same issue when I upgraded the driver for my graphics card, I recommend you install Ubuntu Tweak - it will easily enable you to configure compiz and advanced window effects without the need for a terminal.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.