Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just update to 12.04 from 11.10 and I get to the login screen w/o problems. When I enter my password the screen turns black and returns to the login screen half a second later.

There is a related question out there which was solved by creating more space on the disk but my disks (or rather partitions) are all below 30%.

I can log in as guest. I can also login at the cmd prompt (going to tty with Alt+Ctrl+F1) with my normal user credentials. When logged in as guest I can also install programs using my normal account password.

There is the normal authentication error when I mistype my password so I'm also sure the password works.

Any suggestions?

share|improve this question

Ok I actually figured this one out myself. The problem was that I had installed 12.04 from CD but retained the old home partition. When I created my new user (with the same name as the old one) I got the correct home directory but wrong UID and GID. When I changed it to the correct values everything worked again!

share|improve this answer

protected by Community Apr 29 '12 at 7:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.