Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to the newest Ubuntu release and this broke my ruby on rails setup.

I would like to install ruby 1.9.2-p180 now via RVM:

rvm install ruby-1.9.2-p180

This is cancelled due to some errors with openssl:

ossl_ssl.c:110:1: Fehler: »SSLv2_method« ist hier nicht deklariert (nicht in einer Funktion)
ossl_ssl.c:111:1: Fehler: »SSLv2_server_method« ist hier nicht deklariert (nicht in einer Funktion)
ossl_ssl.c:112:1: Fehler: »SSLv2_client_method« ist hier nicht deklariert (nicht in einer Funktion)
make[1]: *** [ossl_ssl.o] Fehler 1

Sorry as it is in german partially. I can give an english error message if that is necessary. What can I do to get a successful installation?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

You are trying to install old ruby patchlevel.

This is fixed in newer patchlevel:

rvm install 1.9.2

Also pleas note that 1.9.3 is the current ruby version.

share|improve this answer
    
In addition, since it sounds like nblumore did a upgrade, I'd recommend imploding rvm and reinstalling, I've had issues with that in the past. –  jrg Apr 27 '12 at 11:03
    
@jrg you should not need to implode, running the installer should fix everything curl -L get.rvm.io | bash -s stable –  mpapis Apr 27 '12 at 13:22
    
Thanks a lot @mpapis. I wanted to stick to that version as we are using that in a team project. But of course in general we should just use the newest patch. So your answer was appropriate and helpful. –  nblumoe Apr 27 '12 at 14:02
    
@mpapis, I feel your answer runs counter to the purpose of using RVM. Issuing the command rvm list known will display a list of all supported versions of ruby available for installation using RVM. Am also having the same problem installing 1.9.2-p180 and while issuing rvm install 1.9.2 does install a version of 1.9.2, it does not explicitly install 1.9.2-p180. –  Tass Jun 11 '12 at 16:12
    
@Tass it looks like a patch needs to be backported to this ruby, basically you should use latest ruby patchlevel as it solves such problems, but we are happy to provide patches if compilation issues are reported to rvm bugtracker, SO / AskUbuntu are not places to report such problems, we do not track those as a source for rvm fixes. –  mpapis Jun 11 '12 at 21:51
show 3 more comments

Looks like someone actually solved this for us: steps to install ruby 1.9.2-p180 when receiving OpenSSL errors.

In case you don't care to visit the link, here are the steps:

$ bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer )
$ source /etc/profile
$ rvm pkg install openssl
$ rvm install 1.9.2-p180 --with-openssl-dir=$rvm_path/usr

Worked for me, hope it works for you.

share|improve this answer
    
this is half of solution, it uses older openssl, your system ships with newer version which support was added in 1.9.2-p290, this support can be added as a patch for 1.9.2-p180 in rvm, see comments in my answer ;) –  mpapis Jun 12 '12 at 15:16
    
Understood. Perhaps I can convince the rest of our team to move to p290 in production. Thanks for the help, @mpapis! –  Tass Jun 12 '12 at 18:42
    
you should convince them, the patchlevel is only to provide fixes and not to bring breaking changes, basically keeping a patchlevel is not safe as also security updates are introduced in the updates, so unless some serious (and documented) issues stop them from upgrading - they should do that. For updating ruby: rvm get stable && rvm upgrade 1.9.2 will update p180 to p290 –  mpapis Jun 12 '12 at 18:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.