Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Latitude E5510 with an intel GPU, which works absolutely fine, until I plug in an extra monitor or projector. I have a lot of hardware to work with and up until precise, about 40% of the hardware was displaying fine.

One monitor I'm working with (LG E2340T-PN) used to work with oneiric on full HD just fine. no problems at all!
After the (clean) installation of precise I suddenly have to use the 1680x1050 resolution. switching to 1080p just thrashes X.

The monitor I use at home is a Dell 20" (1680x1050 native). I have to switch to 1280x1024 to make my monitor work. If I don't, my screen flickers and jitters and tries to sync (constantly).

The projector I use at home is a SONY VPL-CX76 (1400x1050). no problems with it, at all! a Dell projector at work simply doesn't work at all (getting no signal). We have a couple high end sony projectors as well (1080p monsters), that give me the same jittering as on my monitor at home.

Right now I'm working on the 23" LG (1080p native, but running on 1680x1050 now)
my xrandr output:

VGA1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
1920x1080      60.0 +
1680x1050      60.0* 
1280x1024      75.0     60.0  
1280x960       60.0  
1152x864       75.0  
1024x768       75.1     60.0  
832x624        74.6  
800x600        75.0     60.3     56.2  
640x480        75.0     60.0  
720x400        70.1  


j0lle@j0lle-laptop:~$ lsmod | grep i915
i915                  468651  3 
drm_kms_helper         46978  1 i915
drm                   242038  4 i915,drm_kms_helper
i2c_algo_bit           13423  1 i915
video                  19596  1 i915


j0lle@j0lle-laptop:~$ dpkg -l xserver-xorg-video-intel
xserver-xorg-video-intel              2:2.17.0-1ubuntu4                     X.Org X server -- Intel i8xx, i9xx display driver

I've been looking FOR MONTHS and I can't find a case like mine... Some are quite similar, but never the same. I tried different kernels, different drivers (xorg-edgers), some patches, nothing worked so far.
I'm willing to try anything to get this resolved!

update!!!
https://bugs.freedesktop.org/show_bug.cgi?id=36515#c36
my 1080p is working again! will do more tests with other devices asap

update2
I knew it was too good to be true. 1080p only works when I adjust it with xrandr. xrandr then leaves me with two partially overlapping desktops.
If I adjust it with 'Displays' it's still broken.

update3 I filed this bug: https://bugs.freedesktop.org/show_bug.cgi?id=49220

share|improve this question

closed as off topic by Jorge Castro, fossfreedom Aug 5 '12 at 19:50

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.