Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got this issue after upgrading to 12.04 from 11.10: sometimes, it is not clear what trigger the problem, i start skype and I got this:

:~$ skype
Segmentation fault (core dumped)

If I uninstall and re-install it works for a while but after sometimes/reboot (not a fixed time) same problem come again.

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Solution:

I found that the problem is related to prelink so to solve it you need to exclude skype from prelink:

  1. Add this line to /etc/prelink.conf

    -b /usr/bin/skype

  2. purge skype

    sudo apt-get purge skype

  3. Reinstall skype

  4. sudo ldconfig

More info on this bug here: https://bugs.launchpad.net/ubuntu/+source/skype/+bug/1002187

share|improve this answer
    
according to man ldconfig on Ubuntu 12.04LTS: ldconfig creates, updates, and removes the necessary links and cache (for use by the run-time linker, ld.so) to the most recent shared libraries found in the directories specified on the command line, in the file /etc/ld.so.conf, and in the trusted directories (/usr/lib and /lib). ldconfig checks the header and file names of the libraries it encounters when determining which versions should have their links updated. ldconfig ignores symbolic links when scanning for libraries. Sure etc/prelink.conf is the right place to add that? –  Andrea Borga Aug 2 at 13:41

Frederik answered:

I also experienced this with Skype from Ubuntu’s repositories, but x32.

I now installed Skype again from the official Skype package, and now it works.

share|improve this answer

Temporary workaround

sudo  mv /usr/bin/skype /usr/bin/skype-bin

then

gedit /usr/bin/skype

and copy this:

#!/bin/sh
export LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1
exec skype-bin

Save and exit. Then:

chmod 0755 /usr/bin/skype

It should work.

share|improve this answer
    
Please do not post duplicate answers. If you find that two questions need the same answer, then you need to flag one of them as a duplicate of the other. –  RolandiXor Apr 26 '13 at 13:22
    
This one worked for me on Kubuntu 13.04 and Skype 4.1.0.20. The accepted answer didn't. –  El Barto May 16 '13 at 14:37

I had to remove (rename) the ~/.Skype directory as suggested here http://community.skype.com/t5/Linux/Skype-4-3-crash-on-ubuntu-14-04/td-p/3219892

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.