Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I upgrade to 12.04 (clean install) from 11.04.
I got used to many things in 11.04, one of which is this great work oxygen-gtk

I knew there is gtk3 version, and expected everything to be smooth for some reason. Unfortunately, I soon found out that I'll need not only gtk3 version of this package, but also gtk2 version. This is my issue:

oxygen-gtk3 uses white font color on light background

  • How can I set it to use black font?
share|improve this question
    
You might consider editing the title so its not Theme specific (to be helpful to others) How do set GTK theme font color Preferences? The reason I suggest you emphasize color is that there are much simpler solutions for changing fonts there size and weight in My Unity. Ubuntu Tweak or Advanced Gnome Settings etc –  Stephen Myall Apr 27 '12 at 9:20
    
I'm not sure about that, as oxygen-gtk is not classical theme but depends on special library, thou maybe you are right, maybe it can be issue with other themes, but I don't know –  zetah Apr 27 '12 at 9:33

2 Answers 2

There is kdeglobals file in gtk-3 theme folder - under [WM] section there is setting activeForeground. That setting affects font color

In addition , I was previously successful using this method for the Malys Theme (it may be that some themes are compiled differently)

Go to /usr/share/themes/theme name/gtk-3.0 where there are are .css files You can modify font colors in these files through gedit.

  • Make a back up copy of the .css file before you start (it case things go wrong, you can then revert back)
  • Modify the gtk.css file in gedit.
  • Put in the hexadecimal code of the color you want (This might help)

**Only do this if you are comforatable editing CSS files.""

share|improve this answer
    
I opened it already - there is no setting for font color. I even copied Ambiance gtk.css contents in oxygen (altogether with include files) as there were font settings, but without success, so I revert it to original. –  zetah Apr 27 '12 at 9:22
    
Strange, I answered the question from the top of my head as I did this successfully a few months ago with my favorite Malys theme as I had exactly the same issue. I will check again but unfortunately it won't be until later. Hopefully someone can answer in the interim. –  Stephen Myall Apr 27 '12 at 9:37
    
@zetah You might find this article useful stackoverflow.com/questions/2492861/… –  Stephen Myall Apr 27 '12 at 9:50
    
There is kdeglobals file in gtk-3 theme folder - under [WM] section there is setting activeForeground. That setting affects font color. Stephen if you edit your answer and include this finding, I'll mark it as correct. –  zetah Apr 27 '12 at 10:56
    
I trust you found the atricle useful then (Thanks!) –  Stephen Myall Apr 27 '12 at 11:03
up vote 0 down vote accepted

Provided answer is not enough. Look at this bug report: https://bugs.kde.org/show_bug.cgi?id=299001

So instead explaining how wrong is answered approach I'd suggest to other users to use git version of oxygen-gtk with provided patch, until gtk3 hype calms down. All above things or tweaking gtk.css is wrong approach, and I hope people responsible for packing this theme read this, for everyone satisfaction

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.