Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just performed the upgrade from Ubuntu 11.10 to Ubuntu 12.04 LTS. The updater downloaded all packages but a few ones that the system said were already installed. When asked for it, I chose to install the new maintainer's version of grub.

Now after that my system start up to the login page, some images won't load. Moreover, after I try to login, the graphical instance does not load, it just sits there showing the mouse pointer and nothing else.

share|improve this question
Welcome on AskUbuntu, joksan! Could you please edit your question to explain what you mean by "some images won't load"? What did you expect that is not showing up? Furthermore, what do you mean by "after I try to login"? Do you ever get a graphical instance during the boot? – Agmenor Apr 27 '12 at 3:18
@irrational John : Sir i tried following step 2 but after that i am getting fsck from util-linux 2.20.1 /dev/sda5: 120885.1398096 files (0.2% non-contiguous), 822838/5585408/5585408 blocks blink character Stuck!! – user111257 Nov 28 '12 at 5:44
If you want to provide additional information please do so by editing your question. Don't hide it in a comment. – guntbert Aug 25 '13 at 11:45

I had the same problem. This is how I solved it (parts only in German, sorry; try e.g. Google Translate):

  1. chroot:

  2. Look for the post of bowman Mai 2011 12:52:

  3. Run the following commands in a Terminal:

    sudo apt-get clean
    sudo apt-get update
    sudo dpkg --configure -a
    sudo apt-get -f install
    sudo apt-get upgrade
    sudo apt-get dist-upgrade
    sudo apt-get install --reinstall ubuntu-desktop

This did the trick.

share|improve this answer

Perhaps there's a problem with your desktop environment (or LightDM). IDK which desktop you are running (Perhaps you should add this to your question), so I'm going to assume your running the default one, Unity (aka ubuntu-desktop).

I would try reinstalling both the desktop and LightDM. You can do this by entering a TTY terminal (CTRL+alt+F1 for TTY1, CTRL+alt+F2 for TTY2, etc. CTRL+alt+F7 to return to your desktop). Login, and run:

sudo apt-get clean
sudo apt-get update
sudo apt-get install lightdm ubuntu-desktop --reinstall

From there, I would reboot, and see if that fixes the problem.

If you're using some other desktop, you should be able to replace ubuntu-desktop with the name of your prefered desktop.

share|improve this answer

This is just a generic suggestion and I have no idea whether it will actually help solve your problem or not. But I think it is where I would (try to) start if something like this happened to me.

  1. See if you can boot Ubuntu in recovery mode. Your Grub menu should look something like this:
        Ubuntu, with Linux 3.2.0-23-generic
        Ubuntu, with Linux 3.2.0-23-generic (recovery mode)
        Memory test (memtest86+)
        Memory test (memtest86+, serial console 115200)

    Select to boot using (recovery mode).

    Note: If a GRUB menu is not displayed when you boot Linux, press and hold the Shift key immediately after the system starts booting. This should bring up the GRUB menu.
  2. If you booted in recovery mode, your root (`/`) partition will be read-only. Select/run the option fsck Check all file systems in the recovery menu.

    If this completes successfully, your install partition will be remounted as read/write allowing you to make changes to your files. (If it does not succeed, then something is wrong with your files.)
  3. Select the recovery menu option to Enable networking.
  4. Assuming the above all went well, select the recovery menu option to
    Repair broken packages
  5. Let it run to completion, then reboot. Hopefully this will fix things in your install.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.