Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using Gnome 3.2 since Ubuntu 11.10 was released and it has always been perfectly smooth and performed extremely well, much better than Unity.

After doing a clean installation of Ubuntu 12.04, Gnome 3.4 performs less well. If just one window of a relatively simple application, such as Gnome Terminal, is opened and moved around, the movement is sometimes very choppy, but the rest of the time it's perfectly smooth. The times when it's choppy seem to be when part of the window goes off the bottom or right side of the screen. Also, if there are multiple windows open, it is almost always choppy. These facts suggest to me that it's something to do with the compositor.

Unity works perfectly smoothly. Memory usage is only at about 500-600MB, out of 3GB, even with a few things open. The graphics card is the on-board Intel graphics on the Core i5 M450.

Does anyone have any ideas what might be causing this problem?

share|improve this question
    
Just too see, I tried the newest Intel drivers and Xorg version in the ppa:xorg-edgers/ppa repository, which made no difference to the performance in Gnome 3. I have now rolled back to the "stock" versions of everything –  mjrussell Apr 27 '12 at 14:17
    
I have the very same problem with a NVidia GForce card. I don't think the driver is to blame - it's probably a Gnome thing. Restarting the shell (alt-f2 r) often fixes it, but not always. –  user58142 Apr 29 '12 at 9:52
    
I have now also tried KDE on my installation, which runs absolutely smoothly too. I installed "mutter" from the repositories, which I believe gnome-shell uses under the hood (true?), which has exactly the same problem as gnome-shell with choppy movement. I'm going to try the release-day version of 12.04 on a USB, since I installed from the daily iso the day before release - it shouldn't make any difference though... –  mjrussell Apr 29 '12 at 18:08
    
It's the same on the live USB... –  mjrussell Apr 29 '12 at 18:52
    
same here with ati :( –  biquillo May 22 '12 at 12:55

2 Answers 2

I have found a partial solution to the problem.

It would seem that the root of the problem lies somewhere in mutter or the Intel driver, or a dependency. From https://bbs.archlinux.org/viewtopic.php?pid=1092628, a workaround is to put the following in /etc/environment (or somewhere else which gets "sourced" before things are run):

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

For me, this makes Gnome 3.4 pretty usable, but still a bit worse than 3.2 in terms of performance. The workaround fixes the tearing and choppiness, but it adds lag when moving windows around so that it feels like they're in honey or something!

share|improve this answer

Have you installed the Graphics drivers that come with Ubuntu. If not, you should as it would resolve your "choppy window" issue

Go to Settings >> Additional drivers and search for availaile fglrx graphics driver, then install it. Ensure you you install the recommened option

share|improve this answer
    
It's an Intel graphics card, so fglrx (which is for AMD cards), does not apply. I believe that Intel cards should work "out of the box" on Ubuntu. Direct rendering is enabled and 3D applications work fine. It just seems to be in Gnome the performance is choppy sometimes –  mjrussell Apr 27 '12 at 13:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.