Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

New: After digging around a bit more, I found out the problem is much more that the system is not suspending on its own, although suspending manually (shutdown->suspend) works well. I used the suspend after 5 mins setting on both ac and power from the power settings menu.

The only "solution" I could find for that problem was linked from another thread : http://thecodecentral.com/2011/01/18/fix-ubuntu-10-10-suspendhibernate-not-working-bug Did not work for me.

Old: If I manually (with gconf-editor) set sleep-inactive-timeout to another value other than the 5/10/3/1 from the power manager, the settings will be ignored (= no suspending at all). I set it to 10 and waited 20 seconds. Tried logging in/out and rebooting still the same. Also restarted (killed) the gnome-settings-daemon, still the same.

Am I missing something? If I understand it correctly the gnome-power-daemon (or whatever the name was in older releases) is now completely replaced by the gnome-settings-daemon. Or am I missing an additional package?

Here comes all my settings-daemon dconf-settings:

org.gnome.settings-daemon.plugins.power active true
org.gnome.settings-daemon.plugins.power button-hibernate 'hibernate'
org.gnome.settings-daemon.plugins.power button-power 'interactive'
org.gnome.settings-daemon.plugins.power button-sleep 'suspend'
org.gnome.settings-daemon.plugins.power button-suspend 'suspend'
org.gnome.settings-daemon.plugins.power critical-battery-action 'hibernate'
org.gnome.settings-daemon.plugins.power idle-brightness 30
org.gnome.settings-daemon.plugins.power idle-dim-ac false
org.gnome.settings-daemon.plugins.power idle-dim-battery true
org.gnome.settings-daemon.plugins.power idle-dim-time 10
org.gnome.settings-daemon.plugins.power lid-close-ac-action 'suspend'
org.gnome.settings-daemon.plugins.power lid-close-battery-action 'suspend'
org.gnome.settings-daemon.plugins.power notify-perhaps-recall true
org.gnome.settings-daemon.plugins.power percentage-action 2
org.gnome.settings-daemon.plugins.power percentage-critical 3
org.gnome.settings-daemon.plugins.power percentage-low 10
org.gnome.settings-daemon.plugins.power priority 1
org.gnome.settings-daemon.plugins.power sleep-display-ac 0
org.gnome.settings-daemon.plugins.power sleep-display-battery 0
org.gnome.settings-daemon.plugins.power sleep-inactive-ac true
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 10
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'suspend'
org.gnome.settings-daemon.plugins.power sleep-inactive-battery true
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 10
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'suspend'
org.gnome.settings-daemon.plugins.power time-action 120
org.gnome.settings-daemon.plugins.power time-critical 300
org.gnome.settings-daemon.plugins.power time-low 1200
org.gnome.settings-daemon.plugins.power use-time-for-policy true
share|improve this question
    
Sounds like you've done some good work hunting down a bug! That's very nice. We log bugs on Launchpad.net, however. This site isn't suitable for that, but only for Questions and Answers. –  Jo-Erlend Schinstad Apr 27 '12 at 5:12
    
I don't think its a bug , because it works on other peoples machines. Anyway I reported it here : bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/…. Does anybody know a workaround for that, like a third-party power manager or something similar? –  fvclaus Apr 28 '12 at 11:13
    
Not sure if you saw this answer, but after months of frustration, it fixed it for me. askubuntu.com/a/180505/53508 –  Sparhawk Sep 24 '12 at 23:28

1 Answer 1

Here is a workaround. It requires xprintidle to be installed:

#!/usr/bin/perl 

use strict;
use warnings;

my ($idletime,$suspendtime);
while (1==1){
    $idletime= qx/xprintidle/;
    $suspendtime = qx/gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout/;
    if ($idletime/1000 >= $suspendtime){
    exec("pmi action suspend");
    }

    print "idle: $idletime\n suspendtime: $suspendtime\n";

    sleep 180;
}

Put this in your shell in the background or start it on login.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.