Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to map a network drive running on a windows server..

I tried using the Connect to Server GUI but didn't get anywhere so I tried mounting it in the terminal but have had little success.

basically here are the details of the server I am trying to connect to and what I have tried: (in fstab)

SERVER=10.26.136.12
SHARE=8279
MOUNTPOINT=/home/jacobian/mystuff
FS_TYPE=cifs
SMB_CREDENTIALS=/home/jacobian/.smbcredentials

(.smbcredentials)

username=[domain]/[myusername]
password=[mypassword]

when I try to mount using

sudo mount -t cifs //10.26.136.12/8279 /home/jacobian/mystuff -o credentials=/home/jacobian/.smbcredentials

I get Mount error(13) permission denied.

My credentials are correct because when I log into a windows machine and type \10.26.136.12\8279 and use [myusername]@[domain] [mypassword] it connects and works correctly.

Any help with what I am doing wrong is greatly appreciated.

I am trying to convert my work computer over to ubuntu and this is what makes or breaks it.

thanks.

share|improve this question

3 Answers 3

Having had the exact same problem, installing the package samba4-clients resolved everything and now everything works as before the upgrade when I was on Oneiric Ocelot

so, all I did was:

    sudo apt-get install samba4-clients
share|improve this answer
    
I installed samba4-clients and re-tried the mount command but received the following error: mount: wrong fs type, bad option, bad superblock on //10.26.136.12/8279, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program) In some cases useful info is found in syslog - try dmesg | tail or so' –  jacobian May 2 '12 at 0:14
    
Have you tried connecting to the share via Nautilus? This might bring some clues... Open nautilus-> Press alt to get to the menu, use the command connect to server and enter your information there –  tannerli May 8 '12 at 7:32

It's weird - in Ubuntu 12.04 I'm also having problems connecting to Windows Shares with the Connect to Server GUI. Most of the time, I just can't connect to the Windows Shares!

But if, in the Connect to Server GUI, I use...

Server: MyServerIPAddress; Type: Windows Share; Share: c$; Folder: /; Domain Name: MYDOMAIN (in capital letters); User Name: MyUserName@MyDomain.local; Password: MyPassword

...then somehow I've been connecting to Windows Shares, some of the times!

But if I use the Server's name (instead of IP address), and if I use just MyUserName (without @MyDomain.local), then I can't connect to any Windows Shares at all.

And that's on 2 newly-upgraded Ubuntu 12.04 PC's - one at work and one at home. Both have the same problem.

share|improve this answer
    
Dunno if it helps, but I noticed one of my failed attempts at connecting a Windows Share eventually returned the following error: DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken. –  zamorph Apr 28 '12 at 13:30
    
But all other times, it just says: Please verify your user details. –  zamorph Apr 28 '12 at 13:37
1  
i can confirm this to be a problem on my newly upgraded 12.04 ubuntu box. Also using the above tips it works for me even without @domainname in the username (just DOMAINNAME in capital letters in the domain field and using IP instread of DNS name... –  user58322 Apr 29 '12 at 17:30

One thing that worked for me was to remove the domain from the username and add it in as a separate parameter: domain = whatever.

As stated in an answer above: upper case the domain name!!! .... this appears to be a new gotcha in Precise not present in older versions.

share|improve this answer
    
Thanks, I tried adding a separate line to the smbcredentials file but it still says permission denied. I also tried surrounding the credentials in quotations but that didn't help either.... –  jacobian Apr 27 '12 at 3:44

protected by Community Jun 8 '12 at 9:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.