Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 12.04 and Facebook pictures are not showing up.

I tried all browsers but still can't solve my problem.

enter image description here

Does someone have similar problem? Is there any way to fix this?

share|improve this question

3 Answers 3

up vote 13 down vote accepted
+50

I was encouraged to turn my comments into an answer by Beqa Arabuli and fossfreedom. I posted the solution first in the comments, but bigbadonk420 just put a similar answer. Nevertheless, because it was my idea initially it is legitimate to put another answer here.


It is most likely not an Ubuntu problem as you have changed browsers, reinstalled the OS and done everything that could reasonably be done. The fact that your ping to profile.ak.fbcdn.net is idle means that your are not resolving the address at all (the ping is not being silently blocked as I can ping it successfully). This means that it is probably a dns related issue; you can resolve facebook.com, but not all its content delivery networks (cdns).

That is why other internet sites are fine, but facebook is affected; there must be some kind of misconfiguration in your isp's dns records, or they are blocking the Facebook cdn for some reason. If they are using a transparent proxy perhaps the facebook cdns are getting swept up with that. Anyway, it is impossible to know the exact reason without contacting your isp.

However, the best thing to do is to try an alternative dns; there are several alternatives, but probably the best is Google dns. More information is available from here; you need to set your primary dns as 8.8.8.8 and your secondary as 8.8.4.4 in your Ubuntu network settings and then reboot. You must make sure that your dns is not automatically being set to your original isp's dns. There are more instructions here relating to the setup of Google dns, but it is straightforward and should allow you to solve your problem without contacting your isp.

Go to network-manager > select your connection > click edit and then select the ipv4 tab (if you are on ipv4 as most people are). The screenshot is below: change automatic dhcp to automatic (DHCP) addresses only and enter the dns details in the box provided:

enter image description here

share|improve this answer
    
+50 bounty to you. Thanks again :) –  Beqa Arabuli Sep 16 '12 at 10:30
    
It is not necessary to modify the router settings AND the network settings in Ubuntu. Only one of is sufficient. Though I'd prefer modifying the settings in Ubuntu since it would reduce the DNS requests. –  Dan Sep 16 '12 at 10:32
    
You can do it either way round, but I agree that changing it in Ubuntu is probably best, so I'll edit that. –  user76204 Sep 16 '12 at 11:08

It's almost certainly a connection issue and not mainly a distro issue, unless you have changed the DNS settings on your computer. I see you've already pinged profile.ak.fbcdn.net and that it won't respond, which is what to be expected. When you ping it, what IP adress does it resolve to? (I get 195.12.231.10). Does it resolve at all? If you don't get an IP adress, it's a problem with your DNS server. Try pinging the IP adress directly. Replace your primary DNS with this adress: 8.8.8.8, this is Googles DNS server.

If you do get a correct IP adress and it still does not respond to ping, then the problem is in your network. You need to eliminate eventual culprits like routers or switches, try using ethernet cables if you're using wifi and so on.

If you still can't ping this IP from a "clean" connection (no routers or anything at your house that can create this error) you need to contact your ISP and report a routing error.

share|improve this answer

In my case I had a Firewall Blocking the network where the pictures live. The facebook pictures were serving up as blank rectangles with either red X's or a blue pic icon, but no picture. The picture servers seem to live in Ireland at a subset of fbcdn.net. I unblocked 31.13.0.0/16 outbound for both tcp ports 80 and 443. After this all of the pics showed up.

share|improve this answer

protected by jokerdino Feb 26 '13 at 16:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.