Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Firstly I tried to install the 12.04 upgrade via the update manager GUI from 11.10 after there was no more updates to install and after a fresh reboot but all that would happen is it would say downloading release upgrade tool then that it is nothing else.

So I tried running this from the terminal\command line

brown@brown-Ubuntu:~$ update-manager -d
brown@brown-Ubuntu:~$ do-release-upgrade
Checking for a new ubuntu release
Err Upgrade tool signature                                                     
  Connection failed                                                            
Get:1 Upgrade tool [5612 kB]                                                   
Fetched 5612 kB in 0s (0 B/s)                                                  
WARNING:root:file 'precise.tar.gz.gpg' missing
Failed to fetch
Fetching the upgrade failed. There may be a network problem. 

Can someone please help me out here.

share|improve this question

2 Answers 2

So I've found sorta workaround:

  • Open /var/lib/update-manager/meta-release, and find strings:
Dist: precise
Name: Precise Pangolin
Version: 12.04 LTS
Date: Thu, 26 Apr 2012 12:04:00 UTC
Supported: 1
Description: This is the 12.04 LTS release
Release-File: http://archive.ubuntu.com/ubuntu/dists/precise/Release
ReleaseNotes: http://archive.ubuntu.com/ubuntu/dists/precise/main/dist-upgrader-all/current/ReleaseAnnouncement
ReleaseNotesHtml: http://archive.ubuntu.com/ubuntu/dists/precise/main/dist-upgrader-all/current/ReleaseAnnouncement.html
UpgradeTool: http://archive.ubuntu.com/ubuntu/dists/precise/main/dist-upgrader-all/current/precise.tar.gz
UpgradeToolSignature: http://archive.ubuntu.com/ubuntu/dists/precise/main/dist-upgrader-all/current/precise.tar.gz.gpg
  • Download UpgradeTool and UpgradeToolSignature files
  • Upload them to any other web-server and modify corresponding strings (I guess that even file:/// will work)
  • sudo do-release-upgrade

Worked for me, hope'll help you either. Good luck!

share|improve this answer
  1. Modify the file "/var/lib/update-manager/meta-release" to replace "archive.ubuntu.com" to "old-releases.ubuntu.com"

  2. Run "do-release-upgrade"

  3. When it paused at "Third party sources disabled", open another ssh session to modify "/etc/apt/sources.list" and replace "archive.ubuntu.com" to "old-releases.ubuntu.com"

  4. Continue to upgrade

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.