Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Box.net account and it's feeling neglected so I decided to place my backups there since it's bigger than my Ubuntu One storage.

When I try to set this up I get an error though.

I set it up like this:

  • Backup location: WebDAV
  • Server: www.box.com/dav
  • Use https (yes)
  • Port 443
  • Folder: /Deja/ Username: [email address]

These are the same details used to add my box account as a server in nautilus (which worked) but this says "HTTP Error: Cannot resolve hostname (www.box.com/dav)" when I try to run a backup.

Any ideas?

Cheers,

James

share|improve this question
add comment

4 Answers

I figured it out!

Under your storage tab...
Backup Location - WebDAV
Server - www.box.com
Check the HTTPS box
Port - 443
Folder - /dav/optionalsubdirectory
Username - optional

share|improve this answer
    
Created an account just to comment that this worked for me. Nice job! –  Marc Bernstein Mar 3 '13 at 20:28
add comment

As a workaround you can use davfs2:

sudo apt-get install davfs2

Create a folder where you would like to mount the box.net "drive":

sudo mkdir /media/box.net

Test-mount box.net WebDAV

sudo mount -t davfs https://www.box.net/dav /media/box.net

Make it permanent:

sudo su
echo “https://www.box.net/dav username password” >> /etc/davfs2/secrets`

(username and password of course being your username/email-address and password respectively) NB: Yes, this is your password in plain text but it's visible only to sudoers.

Mount it on every start:

sudo su
gedit /etc/davfs2/davfs2.conf

change the dav_group davfs2 line to dav_group users

sudo gedit /etc/fstab

and insert

http://www.box.net/dav /media/box.net davfs rw,user,noauto 0 0

at the end. noauto is important. Otherwise the boot will hang.

Note that there are several other ways of accomplishing this, for example adding your user to the davfs2 group, having a secrets file just for the user in ~/.davfs2/secrets etc. but this one should work.

All in all I've found the box.net WebDAV support to be flaky at times.

share|improve this answer
    
Awesome! I just got that set up and will now create a backup. Cheers! –  jimmygoska Apr 27 '12 at 21:30
    
Probably off-topic but after setting this up (I wasn't actually able to use it as a backup location, there was an error regarding no permissions to create a directory) I restarted my computer and now it won't get past the splash screen. It doesn't freeze, it just sits there with dots going across. I tried booting recovery mode and the first thing it asks is for my username and password to my box account and then does nothing, hence my thinking it was related. –  jimmygoska Apr 28 '12 at 17:16
    
Do you have noauto removed? This sounds serious. –  turbo May 1 '12 at 23:44
    
....i do..... would it help to boot to a liveusb, edit that file and reboot? I'm not home right now but i can try when i get home. –  jimmygoska May 2 '12 at 19:07
    
Yes, removing the line from fstab will stop the wait. Try removing noauto first, this should be enough. If this doesn't work comment out the whole line. –  turbo May 2 '12 at 20:10
show 1 more comment

As server you can't add URLs like in a browser. You just have to edit Server to "www.box.com" without /dav.

Sorry for the wrong answer. Here the answer
This is a bug in DejaDup and was submitted here: https://bugs.launchpad.net/deja-dup/+bug/975308
You can follow this bug to receive updates and it seems not to work at the moment.

share|improve this answer
    
Just tried changing www.box.com/dav to just www.box.com and I get "Not a WebDAV-enabled share" –  jimmygoska Apr 27 '12 at 0:19
    
I just updated my answer above ;) –  Michael Tanner Apr 27 '12 at 0:21
    
Thanks! I'll keep an eye on that! –  jimmygoska Apr 27 '12 at 0:23
add comment

instead of "noauto" try "_netdev"

_netdev The filesystem resides on a device that requires network access (used to prevent the system from attempting to mount these filesystems until the network has been enabled on the system).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.