Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi everyone and first of all, thanks for your attention - I appreciate it!

Here my problem. I'm new to linux, although I'm a web programmer so command line doesn't look weird to me, and I'm now running Xubuntu. I have made several configurations and installations and it's now working fine, except for this weird thing: terminal window and firefox browser are launching as soon as I log into my account. Does anybody know how such thing could be happening?

I have rebooted several times, logged in/off as well, but both terminal and firefox window come up automatically every time I start a session.

Has anybody run into this before? How can i find a solution to make those apps NOT start on startup?

Thanks again! Hope someone can help me hehe

share|improve this question
    
Thanks a lot for your comment @Matthew but that wasn't really the case this time. I'll keep an eye on those settings though for a possible similar event in the future! –  prubini87 Apr 27 '12 at 2:59
add comment

2 Answers

up vote 9 down vote accepted

There are two possible reasons why the application is started: It is saved in the last session or it is listed in the auto started applications. Follow 1 of the two steps below to get rid of the applications.

  • Start the xfce4-autostart-editor and remove the application(s). You can also manually delete those files in ~/Desktop/Autostart and ~/.config/autostart.

  • Most of the time closing all the applications and save your session when you logout is sufficient. If this doesn't work, remove the content of the ~/.cache/sessions/ directory when you're not logged in. And if you don't want xfce remember every session you should turn off (uncheck) “Automatically save session on logout” in Settings Manager → Sessions and Startup (tab General)

Reference: 1.

share|improve this answer
4  
Thanks a lot @desgua! You helped me find the solution: I just had to remove all files in ~/.cache/sessions/ and that's it - no unwanted apps loading on session startup anymore. –  prubini87 Apr 27 '12 at 3:05
1  
I'm glad it worked :-) –  desgua Apr 27 '12 at 9:33
    
There is another checkbox to save the session in the logout dialog. In my case I had to uncheck that one. I then had to delete ~/.cache/sessions to get rid of the last session that was saved. –  Alexandre Jasmin Aug 2 '13 at 4:45
    
What is this xfce4-autostart-editor? It's not installed in 13.04 and it's not in the repos. Has it another name? –  Peter Flynn Nov 13 '13 at 21:42
    
You should ask it as a new question. –  desgua Nov 16 '13 at 21:35
add comment

The first step is to open startup apps and see what is there, might be as easy as that, if those apps are in startup, you can just remove them

Another option to consider is ubuntu tweak, it can help you regulate how things start

share|improve this answer
    
Thanks @dewb! I've checked which apps were opening at startup but neither Firefox or xterminal (xfce terminal) were in the list (I have posted what worked out for me under @desgua's answer). –  prubini87 Apr 27 '12 at 3:08
    
About xubuntu, well, xfce runs much faster than gnome for me (I'm running linux in a notebook) and since xubuntu comes with it by default, I picked it up :) –  prubini87 Apr 27 '12 at 3:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.