Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Wireless doesn't work on a Broadcom BCM4312

I've just upgraded my Dell Inspiron 1525 to 12.04. Wireless connection worked before, but now it doesn't. I can't seem to start the driver. I remember having to activate it manually for the last version and it worked fine but it doesn't with this new 12.04 upgrade.

When I go to "Additional Drivers", I am shown one option named "Broadcom STA wireless driver". When I try to activate it, I get this message:

Sorry, installation of this driver failed. Please have a look at the log file for details: /var/log/jockey.log

The message entered into the log is:

2012-04-26 22:17:36,194 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted 2012-04-26 22:17:36,491 WARNING: modinfo for module wl failed: ERROR: modinfo: could not find module wl

2012-04-26 22:17:36,492 WARNING: /sys/module/wl/drivers does not exist, cannot rebind wl driver 2012-04-26 22:17:36,556 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted

Can anyone help please?

share|improve this question

marked as duplicate by jokerdino, jrg Apr 27 '12 at 12:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Try running sudo apt-get install bcmwl-kernel-source. –  mikewhatever Apr 26 '12 at 21:41
    
is your notebook 64 bit? –  saiki4116 Apr 26 '12 at 21:50
1  
32-bit. I tried that but it said that I already had the most up-to-date driver. Instead, I removed it using "sudo apt-get install bcmwl-kernel-source" and then installed it again, through the "Additional Drivers" gui. Not sure why, but it worked. Thanks! –  user56926 Apr 26 '12 at 21:58
    
Could you explain further how you got it working. I ran into the same problem. I tried what you said but still could not get it to work. –  user56936 Apr 26 '12 at 22:05
add comment

1 Answer 1

@rdeth use sudo apt-get remove bcmwl-kernel-source command to remove and then install again using additional drivers interface it worked like that for me

share|improve this answer
    
+1 I have exactly this machine and had exactly this problem. Removing bcmwl-kernel-source and then reinstalling through Additional Drivers worked to restore wireless on my Broadcom Corporation BCM4321 802.11a/b/g/n. –  hughdbrown May 1 '12 at 0:58
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.