Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After updating ubuntu to 12.04 all fonts got bold. I haven't installed themes or configured fonts.

from netbeans about:

Product Version: NetBeans IDE 7.1 (Build 201112071828)

Java: 1.7.0_03; Java HotSpot(TM) 64-Bit Server VM 22.1-b02


share|improve this question
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions here. – James Apr 27 '12 at 1:41
add '--laf Nimbus' at the command. Netbeans will look a little different but the fonts will look like before. Your Command: /bin/sh "/home/whatever/netbeans-7.1.2/bin/netbeans" --laf Nimbus – Costis Aivalis May 9 '12 at 20:10
Open queue voters, this question is getting a bunch of traffic, perhaps we should keep it open as it seems to be actively solving people's problems. – Jorge Castro Sep 10 '13 at 13:36
up vote 55 down vote accepted

This is a bug:

In the first link, there is a comment that will point you to another bug. There you can find the following solution:

sudo apt-get remove fonts-unfonts-core
share|improve this answer
sudo apt-get remove fonts-unfonts-core solved my problems. Thank you. – Bakhtiyor Feb 1 '13 at 9:15
sudo apt-get remove fonts-unfonts-core solved my problems. Thank you – loostro Aug 6 '13 at 9:40
Works like a charm! I have been using netbeans 7.3 on ubuntu 12.10 then i upgraded java from 1.6 to 1.7 thats when i got this font issue. After running this command everything went back to normal – indago Oct 7 '13 at 12:03
Thanks, still works after upgrading from 13.04 to 13.10 – mguimard Oct 21 '13 at 13:18
I think this issue surfaces upon installation/upgrading of WINE as fonts-unfonts-core was selected when upgrading WINE from the official Ubuntu repository's 1.4.* to the official WINE-development repo's 1.7.7 (with Ubuntu 13.04). – Alastair Dec 3 '13 at 11:56

In the comments of the bug, there is also a blog post listing two other solutions to solve the problem rather than removing the the fonts:

share|improve this answer
Link only answers are discouraged here. Please edit your answer and include the main parts of the article here. – Parto Apr 25 '14 at 9:16

My Netbeans was showing the IDE font as all italics after an OS upgrade. I ran the command sudo apt-get install fonts-unfonts-core and this resolved the problem.

share|improve this answer

The accepted solution of removing fonts of course works but it's not very elegant

sudo apt-get remove fonts-unfonts-core

instead you can simply change options in Netbeans by editing the file


which you can also find with a simple

find / -name netbeans.conf

and then add the following line to netbeans options:

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal

so you should get a line similar to:

netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-Dapple.laf.useScreenMenuBar=true -J-Dsun.java2d.noddraw=true -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.