Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop is a Lenovo Sl510. It will ask me for my network key and after inputting it, it will drop after about 20 seconds, and ask for the key again, and continuously do this. I never had any connection problems up until trying 12.04 today.

$ dmesg | grep -i firmware
[    0.169851] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[   18.203838] thinkpad_acpi: asked for hotkey mask 0x078dffff, but firmware forced it to 0x008dffff
[   18.637527] iwlwifi 0000:05:00.0: loaded firmware version 39.31.5.1 build 35138
[   28.202028] IBM TrackPoint firmware: 0x0e, buttons: 3/3

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 2 port SATA Controller [IDE mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
02:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
02:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
02:00.4 System peripheral: JMicron Technology Corp. xD Host Controller
05:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)


$ sudo lshw -class network
PCI (sysfs)  
  *-network               
       description: Wireless interface
       product: Centrino Wireless-N 1000
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: wlan0
       version: 00
       serial: 00:26:c7:21:ed:da
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-23-generic firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:49 memory:f2200000-f2201fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: eth0
       version: 03
       serial: c8:0a:a9:24:c4:56
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168d-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:46 ioport:3000(size=256) memory:f2004000-f2004fff memory:f2000000-f2003fff memory:f2020000-f203ffff

$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

How do I solve this?

share|improve this question

6 Answers 6

Try the following, worked for me:

in a terminal type

sudo iwconfig wlan0 power off

in my case, the power-management was broken. if it worked, just do the following to fix the problem on startup

sudo nano /etc/rc.local

and paste "iwconfig wlan0 power off" into it upon (!) "exit0". Save the file and reboot.

I hope this helps.

share|improve this answer
    
I tried doing the sudo iwconfig wlan0 power off command but it just went to the next command line. –  shane Apr 26 '12 at 19:48
    
thats fine. means, that it is done. can you please post output of "iwconfig"? –  Zong Apr 26 '12 at 20:10
    
lo no wireless extensions. wlan0 IEEE 802.11bgn ESSID:off/any Mode: Managed Access Point: Not-Associated Tx-Power=14 dBm Retry long limit:7 RTS thr:off Fragment thr:off Power Management:off eth0 no wireless extensions –  shane Apr 26 '12 at 20:42

I think you might have a bug, but I cannot be sure. I have a Thinkpad X220 with this wireless card and I see this on occassion:

If you can follow Joseph's recommendation in comment #72, try that kernel, and report back on the bug report if the dropping off works it would really help fix this for all Centrino 1000 users.

(You might also have a separate problem, but this is a reasonably educated guess and it won't hurt to try the kernel and then remove it later if I'm wrong)

share|improve this answer
    
I have no idea where to even begin with this, it is way beyond my knowledge of linux. If you can somehow walk me through it, that would help. My biggest problem is I can't connect to any sites on my laptop without having to put in the authentication password over and over so I'm asking here on another computer. –  shane Apr 26 '12 at 20:55
    
To even attempt this you'll need to plug in over ethernet. I'll wait a bit to see what other answers pop up and then I'll write something easy for you. –  Jorge Castro Apr 26 '12 at 21:34
    
I'm gonna go ahead and assume you gave up on this. Screw it, back to 10.04 with me. –  shane Apr 28 '12 at 8:17
    
Ok so I went back to 11.10 and upgraded again today, and it seems that the bug was fixed somehow. I haven't had a problem all day. –  shane May 1 '12 at 9:53

Just had the same identical problem on my dell xps15, tried the power off trick and it didn't work, here's what worked for me instead - at least seems to be working at the moment, 10 minutes without a disconnection so far:

(The following instructions are approximate as I have an Italian installation and I can't guarantee menu items will be exactly as those I mention, if not try to find the closest option) Right click on your wireless icon in the taskbar, go to Modify connections, select the wireless tab, then select your wireless connection (as identified by your SSID) and click on modify. Open the Wireless Security tab, input your key there and click save. Apparently this will make it stick, or at least did for me.

Good luck :)

share|improve this answer
    
I've tried this. I save it, then it will connect, then about ten seconds later it will ask again to input the key, then I'll input it, then everything I saved will be gone again and it will keep asking. –  shane Apr 26 '12 at 21:49

I had similar problems, but with a different card/chip, intel ipw2100.

Changing the IRQ in the BIOS helped for me.

share|improve this answer

The article "Resolve slow connexion when using wifi in ubuntu 11.04, 11.10, 12.04 Precise Pangolin & LinuxMint12" has some good insight. It list there additional solutions you may want to read up on.

http://www.unixmen.com/resolve-slow-connexion-when-using-wifi-in-ubuntu-1104-natty-narwhal/

share|improve this answer

I have the same wireless device in a Lenovo x121e laptop and had similar issues.

I had to disable the Wireless 'n' network. That solved the problem for me.

Try that:

echo 'options iwlagn 11n_disable=1' | sudo tee /etc/modprobe.d/iwlagn.conf >/dev/null

Then reboot the computer. Hope this helps... ;)

Source: Linux iwlagn problems

share|improve this answer
    
I was going to try this so I upgraded to 12.04 again and the problem seems to have been fixed with the package. Thank you for your input! –  shane May 1 '12 at 9:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.