Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Catalyst 11.12 and studying instructions (1, 2) to enable hardware acceleration I ended up with the following command:

sudo apt-get install xvba-va-driver libva-glx1 vainfo && \
vainfo && \
vlc --verbose 2 --ffmpeg-hw video.1080p.x264.mkv

The output confirms that it's using the VA API:

avcodec decoder: Using VA API version 0.32 for hardware decoding.

But even after a reboot the video still looks choppy. There's no vlc output to indicate that the codec is having trouble, or that it's skipping frames. Any idea what could be the problem?

Using vlc 1.1.12 with default settings.

Also tried (in sequence):

  1. sudo apt-get install libva-glx1
  2. sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core
  3. Rebooting

No luck yet.

Specs from /proc/cpuinfo : Intel Core i7 CPU 950 @ 3.07GHz

share|improve this question
    
Are you sure you have the most current proprietary driver? Ubuntu Proprietary Drivers –  John Smithton Sep 27 '12 at 14:46
    
Yep, kept upgrading until I recently realized that the open source drivers had much better performance (moving windows was really choppy with 12.8). –  l0b0 Sep 27 '12 at 14:47

3 Answers 3

up vote 1 down vote accepted

Try upgrading to VLC 2.0.1 if possible.

What processor are you using? The CPU alone should be able to handle 1080p H264 video. That is assuming, of course, that your CPU is decent, and I base that assumption on you having a Radeon HD 6900 series graphics card.

share|improve this answer
    
2.0.3 seems to work great now. Excellent! –  l0b0 Oct 1 '12 at 20:39

Your CPU should be able to decode everything without the need of GPU acceleration.

If VLC doesn't work well you can try a different player: my favorite one is SMplayer (avaible in Software Center).

share|improve this answer

Same problem here. I'm using NVidia an hardware acceleration works fine with mplayer.

Executing vlc -vvv shows the problem looks to be related to avcodec and multithreading:

305 [0xb7049a70] avcodec decoder debug: allowing 4 thread(s) for decoding
306 [0xb7049a70] avcodec decoder warning: threaded frame decoding is not compatible with ffmpeg-hw, disabled
307 [0xb7049a70] avcodec decoder debug: ffmpeg codec (H264 - MPEG-4 AVC (part 10)) started

A custom compilation from VLC sources ("install build dependencies" -> ./bootstrap -> ./configure -> make -> sudo make install) works fine.

share|improve this answer
    
Yeah, most tutorials regarding this recommend compiling. But although I'm more comfortable with make than a few years ago, I'd still very much like to have a managed package. Maybe there's a PPA which already compiles like this... –  l0b0 Apr 30 '12 at 15:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.