Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am try to upgrade to 12.04 from 11.10 using alternative CD. I run this command

sudo gksu "sh /media/iso/cdromupgrade"

after mounted iso as CD. Its gives this error "An upgrade from 'oneric' to 'precise'"

My error message

share|improve this question
Any reason why you're not using sudo do-release-upgrade? – SirCharlo Apr 26 '12 at 18:07
Yes, this is a very odd way of doing it Arul. Alternatively, you could just boot a LiveCD and upgrade the current install from the Installer. – Jjed Apr 26 '12 at 18:09
@SirCharlo I tried this command it gives "No new release found" – Arul Apr 26 '12 at 18:39
@JacobJohanEdwards My internet is very slow. That's why using this method – Arul Apr 26 '12 at 18:40
up vote 1 down vote accepted

Check my image carefully. There is a typo in codename oneiric is correct not oneric.

sudo gedit /etc/lsb-release

and correct this error.


Now everything is working fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.