Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded from 8.04 to 11.10 on my old Compaq Presario. Surprisingly, everything went smoothly and worked. Then the dreaded update module decided that there were 300+ items that needed to be installed. Didn't get past one or two then crapped out. Ever since then when I try to run the updater, I get an error message that I can either close the updater or try a partial install. Partial install says to run:

gordon@Presario-Ubuntu:~$ sudo apt-get install -f
[sudo] password for gordon:
  • This didn't do too well and got the following error msg:

    E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

  • So I tried it and got the following:

gordon@Presario-Ubuntu:~$ sudo dpkg --configure -a

dpkg: error: parsing file '/var/lib/dpkg/updates/0000' near line 22 package 'cups-ppdc':
 EOF after field name `'

I'm no genius at this kind of stuff, so don't know where to proceed from here. Perhaps I should try and install 12.04 from a CD and see if it will upgrade and repair this problem.

And thoughts, suggestions, help would be greatly appreciated. Please remember tht I'm kind of illiterate in the world of Linux and its relatives.


By the way, I cannot install any programs either - just error out.

share|improve this question
Perhaps you can clarify how you went from 8.04 to 11.10 - if you missed out 10.04/10.10/11.04 then this can explain your issues. – fossfreedom Apr 26 '12 at 18:18

That looks like the list of available packages is somehow messed up. You could try manually refreshing the list of available updates. This is the command line way:

sudo apt-get update

Then try the above commands again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.