Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am owner of nVidia GeForce GT 320M and I have two displays: external montior BenQ 1920x1080 and laptop's display 1366x768.

NVIDIA X Server Settings

Ubuntu with installed additional hardware drivers recognize my monitors just as a single monitor:

enter image description here

Similar behavior occurred also on 11.10 but Displays dialog wasn't so important as it is in 12.04:

  • sticky edges make it painful to move the cursor from one display to another
  • when saving a change in Displays dialog or during log in, the following error is displayed:

enter image description here

Displays dialog worked during the installation perfectly. I assume that the problem are nVidia drivers. Output of xrandr:

$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 3286 x 1080, current 3286 x 1080, maximum 3286 x 1080
default connected 3286x1080+0+0 0mm x 0mm
   3286x1080      50.0*

My questions are:

  • How to turn off sticky edges?
  • How to get rid of that dialog after every login?
  • Are there any alternative drivers which play well with Display dialog?
  • How to get rid of nVidia drivers? I could only choose from version current and post-release updates:

Additional Drivers

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

In the last screenshot in your post, you can press Remove on the bottom right. This will remove the closed Nvidia drivers, after a reboot, Ubuntu will use the open-source Nouveau driver. Normally, this works better with the Display system setting.

share|improve this answer
    
When post-release updates driver is installed, you have to downgrade to version current driver and afterwards you can remove it. I haven't noticed it before. –  izidor Apr 26 '12 at 18:18
    
Ah you're right. I had the same experience a couple of days ago. I saw you had the current already activated, so I didn't mention. –  Timo Apr 26 '12 at 18:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.