Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since the "Applications -> Settings -> XFCE Settings Manager -> Keyboard" dialogue does not allow to assign a new key for the "Change keyboard layout" action, I have added a "Keyboard layouts" plugin to the upper panel (near the clock).

It lets me to assign Caps Lock to the change layout action.

But unfortunately, each time after I reboot, the following happens:

  • the "keyboard layouts" applet disappears from the upper panel;
  • I can not use Caps Lock to change the layouts on the keyboard anymore.

How can it be fixed?

P.S. My system is Xubuntu 10.04 LTS, 2.6.32-40-generic

share|improve this question
add comment

2 Answers

  1. Settings Manager - Keyboard - Layout. Uncheck "Use system defaults".
  2. http://ubuntu.sabza.org/2006/10/13/xubuntu-easily-switch-keyboard-layout/
share|improve this answer
    
This doesn't work for me. It appears to be a bug the OP is describing. –  Evan Carroll Jun 19 '12 at 15:52
add comment

I worked around this problem by changing the System Default Keyboard. This works on a single-user system (or system where everyone will use the same keyboard) just fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.