Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using a Mac with an Apple Wireless Keyboard - French.

I have installed Ubuntu as virtual machine by VMware Fusion. The keyboard setting of Ubuntu is as follows:

enter image description here

And the preview is not exactly as Apple Wireless Keyboard - French:

enter image description here

In Mac, we can type \ and [ by:

  • \ = Option ⌥ + Shift ⇧ + :
  • [ = Option ⌥ + Shift ⇧ + 5

However, it doesn't work under Ubuntu. Could anyone tell me how to type \ and [ under Ubuntu? Also, is there a keyboard other than French, that I currently set, which fits better my Mac keyboard?

share|improve this question
up vote 3 down vote accepted

I'm setting on a macBook pro - same keyboard pretty much!

I've switched my layout to My Language [Macintosh] - now i can make:

[ ]RightAlt8 & RightAlt9
{ }RightAlt7 & RightAlt0
\RightAlt+

So it's pretty much the best solution i found, as it makes it manageable by doing it as windows normally do, but it's sorta off from the normal mac way.

On a side note i have my Cmd button mapped with Ctrl and made some changes so it functions almost like Cmd button in OS X. - This way i lost the Super key but it's more to my liking ;)

share|improve this answer

For a single occasion I would resort to Unicode: Ctrl+Shift+u, 005bReturn for left bracket and Ctrl+Shift+u, 005cReturn for backslash.

For a long-term answer we'd want a single keypress, but I'm just not sure how to get your layers of software to align.

share|improve this answer

Did you gave a try to Keyboard-configuration?

In my case (Ubuntu 12.04 server on MacBookPro 10.9 within VirtualBox 4.3.8 (ok, not Fusion, but similar conditions right?), here is what I did:

sudo apt-get install keyboard-configuration sudo dpkg-reconfigure keyboard-configuration

keyboard-configuration choices for MackBookPro French keyboard:

1. MacBook / MacBookPro (Intl)
2. French
3. French (yes, again)
4. Right Alt (AltGr)
5. No Compose Key

Seems keyboard settings works fine and are keep after reboot.

I may have to tests some other parameter value for 2. 3.and 5.

It took me 5 minutes to find out the right parameters for you: hope it will be that fast for you

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.