Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Maverick on a Sony Vaio VPCEA24FM. I have no sound. I've gone through the guide at https://help.ubuntu.com/community/SoundTroubleshooting up to the section titled, "Is the system recognizing your sound card?" When I run the terminal command in that step:

sudo aplay -l

I get the following response:

aplay: device_list:235: no soundcards found...

The machine does actually have an onboard soundcard; it works fine when I run Windows.

When I run hardware lister (lshw-gtk), this is what shows up for audio: alt text

Can anyone help me out? I really want to switch over to Linux completely, but I can't do it if I don't have working sound.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I did finally get it to work by using the ALSA upgrade script on ubuntuforums. The first time I ran it, I got compile errors when running this line:

sudo ./AlsaUpgrade-1.0.23-2.sh -c

I went back and ran

sudo ./AlsaUpgrade-1.0.23-2.sh -s

to get the snapshot ALSA release for Maverick, and that did it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.