Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 on an Asus G71-GX with an Intel 82801JI (ICH10 Family) HD audio controller (using the HDA Intel driver). The codec is a Realtek ALC663.

When I plug in headphones (using the built-in 1/8" stereo jack), They are detected and the audio level is appropriate but the sound through the headphones is very quiet. Tested with multiple headphones, Jack works fine in Windows.

Any suggestions?

share|improve this question
    
Actually, if I look in the output devices shouldn't I see headphones as an output choice? I don't... –  Tohuw Apr 26 '12 at 3:11
    
I have the same problem on my X220: natalian.org/archives/2011/11/10/Thinkpad_X220 –  hendry Apr 26 '12 at 4:50
    
You do not seem to have the same problem at all. The only reference I can find is a note regarding low overall volume. –  Tohuw Apr 27 '12 at 2:38
add comment

5 Answers

Here's the best solution that I've found:

Open terminal and run alsamixer

You will see the mixer. When you plug the headphones into the laptop note that the "Speaker" column becomes "MM" (muted). Raise the level in that column and you will hear the normal sound level.

share|improve this answer
    
Thank you! My answer ended up being a little bit different, but you lead me to the right line of thought. Much appreciated! –  Tohuw May 2 '12 at 1:19
add comment

This is a old post but the following might be of help: http://oldpapyrus.wordpress.com/2013/08/07/fix-low-volume-with-hda-controller-on-linux/

share|improve this answer
3  
While this may answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  edwin Aug 8 '13 at 4:44
add comment
up vote 0 down vote accepted

Maxym assisted me in finding the correct answer. In his case, the speaker was becoming muted. I had checked for that previously, but he lead me to consider the levels of seemingly unrelated items.

I eventually found that my "Bass Speaker" was set to 0 by default, but is actually mapped to my headphone jack. The level has no effect through the laptop speakers, but it is actually the headphone volume.

It is worth noting that this does not present itself at all in gnome-control-center sound-nua. The only similar setting is "Subwoofer Level" and it is always grayed out.

After running alsamixer, changing the volume of "Bass Speaker" to 100, then closing alsamixer and opening it again, the level was now properly labeled "Headphones", but it still did not appear anywhere in the GTK-based controls.

I also noticed setting the Master volume has no effect when the headphones are plugged in, except that all sound is muted when the level is decreased to 0.

So, should future distraught users stumble across this, check the level of everything in alsamixer; that might work for you too.

share|improve this answer
add comment

Same problem on my notebook with Intel HDA - Realtek ALC269VB: Plug in a headphone mutes speakers but very low sound on headphones. In Alsamixer the Speaker slider drops down to zero as soon as headphones are plugged in and it restores the previous volume when headphones are plugged out. Speaker slider can be manually raised to get sound on headphones but it will drop to zero again whenever you plug-in the headphone next time.

share|improve this answer
add comment

Open pavucontrol and set the audio level and close--this should save your settings.

share|improve this answer
    
I installed pavucontrol, and I do have options there to set the headphones volume. However, even at the max (153%), the sound is very quiet. –  Tohuw Apr 26 '12 at 3:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.