Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Ever since Ubuntu 11.10, it has seemingly been impossible to hide Rhythmbox and have it display just a tray icon. Instead, when lowering it, it is still shown in my Window List down the bottom of my screen, which is needlessly taking up space.

In the past, when closing the Rhythmbox window, it would disappear from the screen completely, and just show a tray icon in the top right hand corner of my screen, which I could use to show/hide it.

I'm using Ubuntu 12.04 now, and it has exactly the same problem with this as it did in 11.10. I'm using the Gnome Classic desktop. Rhythmbox is displayed in the sound section of the indicator-applet, but I can't see any way to get it to hide completely.

Is there any way to replicate the old pre-11.10 behavior where it would display only a tray icon and nothing else?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I'm using the Unity desktop and closing it works for me(the X icon not of the _ icon). It doesn't actually close, it just hides. If this doesn't work on Gnome3, you should file a bug report.

share|improve this answer
Ah, so that's the problem. Thanks for that. I could swear that it used to work with the _ icon before, though. – paul88888 Apr 26 '12 at 1:32

I was on a similar hunt and ended up using this tray icon plugin, which stays visible after closing the Rhythmbox window. It seems like a recent behavioral change but I can't find a way to toggle the behavior of the X.

share|improve this answer

Canonical decided to remove the sys-tray icon from Rhythmbox because (and I'm paraphrasing here) "The system tray should not be used as a location to minimize programs". This causes issues with every distro that isn't Unity, Mendhax has created a plugin that restores this function for you.

Personally I think they should have left it in as a plugin but disabled by default so it can easily be restored by those of us who want it but Canonical does what it wants, and they want it completely gone.

share|improve this answer
Quote "Mendhax has created a plugin that restores this function for you." Where is it ? how do you install it ? Would be good to add this to your answer, not just mention that somewhere and somewhen a plug in may exist – mark kirby Aug 4 at 7:23
@markkirby here you go: – Ddorda Sep 28 at 19:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.