Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background:

  • I installed Ubuntu 11.04 on my desktop, well, after April last year.
  • I upgraded in November to 11.10.
  • Around a month ago, I popped the SATA and power cables for the hard drive Ubuntu is on and installed Windows 8 CP to the second hard drive. (to see if I could use it as a desktop OS)
  • Three days ago, I re-connected the Ubuntu drive, used update-manager -d to go to 12.04 pre-release, and did update-grub to make sure it found the new partition. Also, I switched my default boot HDD to the Ubuntu one. (It continued to default to the Win8 one even after re-connecting the Ubuntu one.)

Now, when I boot, I get GRUB, and can boot Ubuntu just fine. GRUB also includes an entry for Windows 8 Loader. This entry will show the Beeta Fish (showing that it is in fact booting Windows 8 or some lower-level part thereof) onscreen and then a message flashes by which is 7 or 8 lines long but I cannot read. Then, my computer starts up again and I see BIOS/POST come up as though I had hit the power button following a successful power off.

Changing the default boot HDD or using the menu activated by pressing F8 during BIOS/POST to select the proper drive both result in a successful Windows 8 boot.

How can I either a) reconfigure GRUB to properly boot Windows (of course, while still booting Ubuntu) or b) configure the Windows bootloader to show up and give me the option of the Ubuntu hard drive (in which case I would turn off the GRUB menu and use the Windows drive as my default).

Using another bootloader (for instance, BURG) is okay, so long as you provide simple instructions and the boot-loader is open-source and available by PPA or a .deb file.

share|improve this question
    
I'd accept other answers, the one I marked as correct is OK but I'd prefer an answer that allows GRUB to work. –  Andrew Jul 21 '12 at 22:21
    
A weird thing happened to me, yet similar to yours - I successfully managed using GRUB2 to boot both Ubuntu and Win8, yet when I switched to BURG, I got the few line message in Win8 and a reboot right after. I went to Advanced System settings in Win8 and disabled Automatic Restart in order to see the message. Unfortunally, the message is only a few lines of memory addresses and then note that Win8 needs to reboot. :/ However, this issue is very interesting because it worked perfectly from GRUB - I'll let you know if I discover what's going on. –  Shomz Apr 26 '13 at 20:24
    
Thanks. My solution ended up being to use Windows 7. I'm planning on going back to 8 at some point. (Windows 7 64-bit is being freaky, and I want to see if 8 is too). –  Andrew Apr 27 '13 at 1:19
    
I loved the 8 (64-bit), so I'm staying with it. Basically, it's enhanced 7. My solution for booting it is just to select its MBR partition as a boot device during BIOS POST. I've opened my question about this here on SuperUser so let's hope someone knows what's going on. –  Shomz Apr 29 '13 at 13:16

3 Answers 3

up vote 3 down vote accepted

You can use EasyBCD (freeware) to add Ubuntu to the Windows 8 bootloader. Be sure to add the entry as GRUB2 and not Grub Legacy (the default).

(Disclosure: I'm the author)

share|improve this answer
    
Cool! I've heard of your program before. –  Andrew Apr 26 '12 at 17:52

I found your question after posting my own report of the same problem at How to fix insta-crash on dual booting Windows 8 from separate drive. I was able to take a video of the crash and extract the frame that shows the error message. See http://i.stack.imgur.com/eNzTk.jpg.

I don't have an answer yet.

share|improve this answer
1  
Thanks for the data! I ended up just going with EasyBCD for the remainder of using Windows 8, and kept it when I switched back to 7. –  Andrew Nov 5 '12 at 12:38
1  
You can see this message (and similar ones) by disabling Auto Restart in Advanced system options. Strongly suggested! –  Shomz Apr 26 '13 at 20:26

It's my understanding you can't boot grub on a windows 8 disk. Windows 8 has to have a windows MBR. You can still chainload to the windows 8 loader, but what it sounds like to me is that you installed grub to the win8 HD(you're not allowed to do this).

share|improve this answer
    
I'm not booting GRUB on the windows 8 disk. GRUB is on the HDD with Ubuntu. I want to know how to make GRUB successfully chainload the windows 8 loader, and it isn't working. I want to know how to fix it. –  Andrew Apr 26 '12 at 17:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.