Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded to the 12.04 beta yesterday. Now, when I try to start Eclipse, I get the splash screen and then this error message:

An error has occurred. See the log file /home/gabriel/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/1335382319394.log .

The log file says something like this:

java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
    no swt-gtk-3740 in java.library.path
    no swt-gtk in java.library.path
    Can't load library: /home/gabriel/.swt/lib/linux/x86_64/
    Can't load library: /home/gabriel/.swt/lib/linux/x86_64/

followed by many more error messages.

The /home/gabriel/.swt/lib/linux/x86_64/ directory exists, but is empty. I also tried reinstalling eclipse with no success.

Any ideas?

share|improve this question
This is a bug. Please log into Launchpad and register that this also affects you: – David Edwards May 25 '12 at 10:59
up vote 19 down vote accepted

I have got the same issue in an AMD64 machine (Ubuntu 12.04). and solved it by a workaround:

copy: files containing '3740' in /usr/lib/jni/libswt-* to ~/.swt/lib/linux/x86_64/

But, be sure the packages : libswt-gtk-3-java & libswt-gtk-3-jni are installed.

sudo apt-get install libswt-gtk-3-jni libswt-gtk-3-java


sudo cp /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86_64/

if you have a 32 bits based system : sudo cp /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86/

share|improve this answer
wow this actually worked for me too (Intel core i5, 64 bit ubuntu 12.04) thanks a lot! – vallllll May 1 '12 at 9:57
Worked great for a 32-bit system. Using: sudo cp /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86/ . Thanks and update your answer please. – Binarylife May 3 '12 at 9:24
It really works for me either (Ubuntu precise 64 bit). I had created soft links instead of copy. – masuch May 4 '12 at 23:11

Try running

sudo update-alternatives --config java

and selection open jdk. This would probably work.

share|improve this answer
This did work, but I'm trying to avoid using openjdk. – Keidax Apr 25 '12 at 19:58
Actually, never mind. I'll just go with it. – Keidax Apr 26 '12 at 1:58
I also wanted to avoid openjdk, so check out Hanynowsky's answer; it worked for me! – Nick Badal May 2 '12 at 22:34

Also for me it works; I done:

cd ~/.swt/lib/linux/x86_64
ln -s /usr/lib/jni/
ln -s /usr/lib/jni/
ln-s /usr/lib/jni/

and so, I created 3 symlink in the folder ~/.swt/lib/linux/x86_64

Now Eclipse works fine!

share|improve this answer
echo "-Djava.library.path=/usr/lib/jni" >> /etc/eclipse.ini

fixed it for me.

share|improve this answer
Love this solution, fixed it for all users. – Adam Ness Aug 11 '12 at 19:08

Thanks for the great instructions. I added symlinks like this instead, to make sure it picks up all 3740:

cd ~/.swt/lib/linux/x86_64

for i in /usr/lib/jni/*3740*.so ; do ln -s $i; done
share|improve this answer

I made symlinks to the missing libs and everything worked fine. It ended up looking like this... -> /usr/lib/jni/ -> /usr/lib/jni/ -> /usr/lib/jni/

Seems to work.

share|improve this answer

protected by Community Oct 21 '12 at 8:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.