Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When updating I got this error message:

W:Failed to fetch cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)/dists/oneiric/main/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
W:Failed to fetch http://ppa.launchpad.net/synce/ubuntu/dists/your_ubuntu_version/main/source/Sources  404  Not Found

What to do?

share|improve this question

8 Answers 8

The issue here is that your OS is looking for CD-ROM in the apt sources list. To fix this:

sudo vi /etc/apt/sources.list

Remove any lines that include CD-ROM. Save the file and try once more.

share|improve this answer
    
Thanks just going to try it, so far only found one line with cd-rom in it is. deb cdrom:[Ubuntu 11.10 Oneiric Ocelot - Release i386 (20111012)]/ oneiric main restricted –  Mattlinux1 Apr 9 '12 at 23:33
    
Yep, you can either remove it or comment it out by placing a # at the beginning of the line. –  RWC Apr 9 '12 at 23:35
    
Done Thanks man, its now saying its updated. :) –  Mattlinux1 Apr 9 '12 at 23:37

Run "Software Sources" and uncheck checkbox near "Cdrom with Ubuntu" enter image description here

share|improve this answer

The W: lines are warnings. The first one is because you still have your install CD (the one you used to install Ubuntu in the first place) listed as a possible software source, but it is not in your drive at this time (reasonable, ignore it). The second is because you have copied a URL (web address) verbatim and not changed your_ubuntu_version to the name of your Ubuntu version. It should read http://ppa.launchpad.net/synce/ubuntu/dists/oneiric/main/source/Sources instead, since you're using Oneiric Ocelot (11.10).

You can access Software Sources through the Ubuntu Software Centre to make changes to your source lists - https://help.ubuntu.com/community/Repositories/Ubuntu#Adding_Repositories_in_Ubuntu

share|improve this answer

Maybe you should have a look at this link Basically what you need to do is open software center, go to edit> sources and uncheck cd rom from there

share|improve this answer

It is trying to use the repositories on the CD you used to install Ubuntu but cannot access them (potentially because the CD is not in the drive). Assuming that you have an internet connection that you can use for installing new software (and updates) you can safely disable the repositories on the CD.

To do so:

Hit Alt+F2 then type gksudo software-properties-gtk and enter your password in the dialogue that comes up.

Now in the window that comes up you should be able to disable using the cdrom repositories by unchecking them in either the bottom of the "Ubuntu Software tab" or in the "Other software tab" (most likely in the former location). Hope this helps.

share|improve this answer

Sounds to me like you have your update manager looking for updates on the installation CD. I would suggest installing Synaptic if it's not already installed and then using that to take a look at your software sources.

sudo apt-get install synaptic

then Load Synaptic Look for Settings > Repositories in the menu.

Go to the Other Software tab and make sure cdrom is not 'checked'. You may also want to uncheck the items in that list for Skype. Then close that window, and hit the Reload button in Synaptic

share|improve this answer
    
For skype, you can just download the latest version from skype.com skype.com/intl/en-us/get-skype/on-your-computer/linux –  warkior Nov 8 '12 at 17:21
    
when i use that i get this: Failed to fetch archive.canonical.com/commercial-ppa-uploaders/skype/ubuntu/… 404 Not Found [IP: xxxxxxxxx] Failed to fetch archive.canonical.com/commercial-ppa-uploaders/skype/ubuntu/… 404 Not Found [IP: xxxxxxxxxxxxx] Some index files failed to download. They have been ignored, or old ones used instead. i just want to keep using it like i used 12.04 but this is making me nervous:/ thank you! –  MrZazhy Nov 8 '12 at 17:56

Removing the CDROM from repositories should solve the problem (since apt-get is trying to read from cdrom which is not there). Just go to System->Administration->Software Sources and uncheck CDROM...

Now, this is the solution if you want to upgrade packages over the Internet. I don't yet know the solution for actually upgrading from CD (I just know you should run apt-cdrom add after inserting a CD with a newer Ubuntu version, but it seems apt-get upgrade ignores the CD) - someone else could help with this...

share|improve this answer

You have selected the CD-ROM as software sources, so it is checking the CD-ROM for the source.

To uncheck CD-ROM option go-to:

  1. system settings

  2. software sources

  3. other software

  4. uncheck CD-ROM option.

This will solve your problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.