Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 12.04 on a toshiba L305D with athlon x2 (Already suspect this has something to do with it). My laptop will wake from suspend, presumably from wireless scanning. This is a serious bug as sleeping laptops are often inside bags, so the cooling system is effectively disabled. I can no longer seriously use Ubuntu when I have to worry about hardware damage every time I close the lid. There is shockingly lack of information about anything close to this. So many control panels have been removed or dumbed down, and everyone seems to want this behavior instead of the opposite, for servers or torrents of whatever. Well, most laptop users will 99% be likely to regularly put their laptop in a backpack or briefcase or other bag. Does anyone know how to fix this?

share|improve this question
    
Search your BIOS settings on what is allowed to wake up your laptop (LAN, USB, timed wakeup) and disable the ones you don't use (I think you'll only want to use keyboard) –  jP_wanN Apr 25 '12 at 16:39
    
@jP_wanN That could be a good idea. Could you add that as an answer? –  hexafraction Jun 28 '12 at 20:01
add comment

2 Answers

Search in your BIOS settings for what is allowed to wake up your laptop (LAN, USB, timed wakeup) and disable the ones you don't use (You'll probably only want to use keyboard and perhaps mouse)

share|improve this answer
add comment

I had this issue as well. There could be a few reasons why.

For me it turned out to be my wireless mouse's receiver being connected to the laptop. It seems the mouse pings the receiver which talks to the laptop through the USB which makes the laptop wake up. So now I unplug the mouse receiver from the USB. If it's not that, try unplugging/undocking everything from the laptop and see if it still happens.

@jP_wanN's comment above about booting to the BIOS about disabling things like wake-on-lan and other "Wake" features is also a step I took. Your mileage may vary based on the BIOS you have (may want to update it if some Wake features are not there).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.