Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have updated to the latest 12.04 and it removes the pygtk bindings for python2.6.

I've looked at the python-gtk package and it now installs only the lib for python2.7.

The problem is : I have an application that depends on gtk and python2.6 and I am sort of stuck : I cannot go to python2.7 and there is no package that install it for python2.6.

Note : I have the application source code dealing with gtk, so if necessary I can do the porting from gtk2 to gtk3 (gi.repository and stuff).

share|improve this question
1  
Why can't your program run under 2.7? Are you using features specific to 2.5 that have been removed? It should be easy to fix your code to work with 2.7 as well as 2.6 (and even python3 if you're willing to port to the GI bindings instead). –  dobey Apr 25 '12 at 17:00
    
The code use Panda3d a game/3d engine that have bindings only for python2.6. It is a huge dependency and The binding method Panda3d is very specific. Without the proper knowledge, this would be a very long project. –  LBarret Apr 25 '12 at 19:37
    
Updating to the last version of Panda should help you. –  Javier Rivera Apr 26 '12 at 7:18
    
Why ? The release note says nothing of python2.7, AFAICT the bindings are still for python2.6. –  LBarret Apr 26 '12 at 9:42
    
The features page for Panda says "All Python versions from about 2.4 to newest 2.x supported." –  Thomas K Apr 26 '12 at 10:38
add comment

1 Answer

I solved a same problem related python-httplib2.

below is that I try.

sudo apt-get source python-httplib2
cd python-httplib2-0.7.2/
sudo python2.6 setup.py install

maybe you can try with pygtk package. I wish this will help you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.