Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This often happens to me. I go to install a program and it says I am missing certain dependencies. Then I run apt-get build-dep and get an error message like the following:

sudo apt-get build-dep gnome-shell
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have unmet dependencies:
libgjs-dev: Depends: xulrunner-dev (< 1.9.2.4~) but 1.9.2.10+build1+nobinonly-0ubuntu0.10.04.1 is to be installed
librsvg2-dev: Depends: librsvg2-2 (= 2.26.2-0ubuntu1) but 2.26.3-0ubuntu1 is to be installed
E: Build-dependencies for gnome-shell could not be satisfied.

What should I do to fix this problem when I thought this was exactly the kind of problem build-dep was designed to fix. Thanks.

share|improve this question

1 Answer 1

apt-get build-dep is intended to be used by developers to install the build dependencies of a packages; i.e. the packages that are required to compile the package's source.

Regarding the unmet dependencies issue, based on the version numbers that you have posted, it looks like you either have outdated package information, which can be fixed by running sudo apt-get update, or you don't have the lucid-updates or lucid-security repositories enabled.

See https://help.ubuntu.com/community/Repositories/Ubuntu for help enabling additional repositories in Ubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.