Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ubuntu 11.10. I noticed that when I click on an HTML file in the file manager (I happened to be using nautilus 3.2.1 file manager), then firefox will open allright, but it opens hidden behind the file manager window that I was looking at when I did the clicking.

Is there an option to make the application that opens, to open in the front of all windows, so that I do not have to go search for it each time where it opened (have to go move windows all the time).

It will be nice actually if there was a bar thing where current application that are open are arranged on, so I can at least see what I have open.

thank you

share|improve this question
    
This is really starting to get very annoying. I have workspace switcher with 4 separate virtual desktops. When I am in one of the 4 and click on an HTML file inside the file manager, I now have to open all 4 virtual desktops looking for the browser to see where the page I opened is. Is this what people call user friendly? All what I want is click on the html file and have something open it to view in front of me and not have to go search for it. No one knows how to make such a simple thing happen on Linux? I am newbie and just trying it. –  Robert H Apr 26 '12 at 1:58

1 Answer 1

This is controlled by settings in your Windows Manager regarding focus.

In Xfce (which I use), go to Settings, Xfce Settings, Windows Manager Tweaks, then click the Focus tab. Make sure "Prevent focus stealing" is turned off, and "Honor standard ICCCM focus hint" is turned on.

If you use some other Windows Manager, you should be able to find similar focus settings somewhere.

share|improve this answer
    
I looked at the preferences for ubuntu 11.1, I am using default window manager that came up from installation (ubuntu classic). I do not see anything there regarding this. I used the search window there also, searched for "focus" and nothing came up. –  Robert H Apr 25 '12 at 13:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.