Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the title suggests I would like to confirm my assumptions and get a better understanding of the Ubuntu software repositories in terms of what is supported and getting updates. I will use GIMP as an example (but this question is NOT about GIMP) it’s a general question about repositories.

I know I can install GIMP from the USC and currently its version 6x

From another repository “add-apt-repository ppa:otto-kesselgulasch/gimp” I can install Gimp v8x

Are these assumptions correct?

  • Both versions are supported
  • Eventually v8 will be available in USC in the Ubuntu Repositories to install
  • I may have future issues during updates using a PPA that is not in the USC.
share|improve this question
    
If your questions about ppa only ,then this is a duplicate e,If you mean all repositories this may not be a duplicate –  Tachyons Apr 25 '12 at 9:58
    
Thanks, my question was general and is about any software source for Ubuntu. I only used the PPA as an example. I did search this site for possible duplicates but didnt find the holistic answer I needed (although I did find clues). The accepted answer below totally meets my expecation. I am always tempted by the latest and greatest software but I wasnt clear what harm they could do to my system or what steps I could take to ensure their reliability. Thanks! –  Stephen Myall Apr 25 '12 at 11:03

2 Answers 2

up vote 2 down vote accepted

You can read about repositories here.

ppa:otto-kesselgulasch/gimp is a PPA (personal package archive) - kind of a personal repository.

Its description says:

CAUTION!

This PPA could break your installed OS. There are dependency issues 
especially for Oneiric (11.10). Only use it if you know what you do! I'm 
working with others on a stable and reliable solution.

Gimp is currently at version 2.8, but older Ubuntu releases have older versions, which are maintained either by Ubuntu developers or the community.

share|improve this answer
    
I have learned 2 things here by selecting the links you provided. 1: My assumptions were wrong and 2: I should do some kind of sanity check (probably in Launchpad) on a PPA I see on a website if Im not sure of it origin, reliablity or compatibility with my OS. –  Stephen Myall Apr 25 '12 at 10:09

If there are multiple versions, the system will use the latest version. If the newer version is added and doesn't work, the user will need to purge the PPA and packages used from it. (More info about purging)

This is a great reason to have a virtualbox machine of the distro you are using, you can test things like this before committing the changes to your actual machine.

share|improve this answer
    
This answer is also useful, however i dont want to get to the point were I have to test (Im not a techie). I guess I could also have phrased my question: How Do I know (or find out) if a repository outside of Ubuntu is reliable, before using it. Thanks a million –  Stephen Myall Apr 25 '12 at 10:35
1  
It really depends what is meant by 'reliable'. You're probably not going to have a launchpad based PPA put malware on your system but I have had PPAs with updated video drivers break my system for a few days. You can also check the forum for that particular PPA, if applicable, and see if others are having issues. In regard to the PPA you mentioned, it seems to be working well at the moment and I will be switching to this as my ppa only uses 2.7.4. There's no guarantee that the maintainer will not break things in the future, however. –  Veazer Apr 25 '12 at 14:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.