Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There is a display bug that I've been trying to find information on for a while now involving the "eMachines E525 Notebook computer" and it's "backlight", when using Ubuntu, Xubuntu, Lubuntu, and Kubuntu 11.04-11.10. Every time my computer gos to sleep the backlight gets shut off.

All I could find online was that I had to switch to the root of the system and edit the /etc/rc.local file, adding setpci -s 00:02.0 F4.B=00 before the exit 0 at the end of the file. I did, and when I restart the computer I can see that the backlight is on, however when the computer gos to sleep or the lid gets closed, the backlight goes off and I have to open "Terminal" and type in sudo setpci -s 00:02.0 F4.B=00.

I guess my real question is, is there a line of code I could enter into the grub menu or the /etc/rc.local file to make the backlight stay on? If anybody has any possible fixes for this bug, and would like to share the information with me, it would be highly appreciated.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Creating a script in /etc/pm/sleep.d/ to run the command should work.

gksudo gedit /etc/pm/sleep.d/99_backlight

copy/paste the following:

#!/bin/sh

# run 'setpci -s 00:02.0 F4.B=00' when waking up

case "$1" in
        thaw|resume)
           setpci -s 00:02.0 F4.B=00
            ;;
esac

save and exit, then make it executable with

sudo chmod +x /etc/pm/sleep.d/99_backlight
share|improve this answer
    
OK, I'll try it now. –  David Yenor Apr 25 '12 at 8:17
    
Thank you, it worked. I really appreciate the help, this was really the only issue I've ever had with Ubuntu. It was driving me mad. –  David Yenor Apr 25 '12 at 8:30
    
Glad it helped. :~) –  mikewhatever Apr 25 '12 at 8:39
    
...and since it worked, you might as well want to accept the answer. –  mikewhatever Apr 25 '12 at 15:42
    
Thank you, but way it not fixed in relese 12.10? In canonical know about this problem? Please confirm the problem to see it developers: bugs.launchpad.net/ubuntu/+source/acpid/+bug/392948 –  user56124 Oct 22 '12 at 1:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.