Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just updated one of my servers to 12.04 (from 10.04), and Xorg no longer starts, nor will lightdm or gdm.

Looking in /var/log/lightdm/x-0.log:

X.Org X Server 1.11.3
Release Date: 2011-12-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.42-23-generic x86_64 Ubuntu
Current Operating System: Linux murph 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64
Kernel command line: root=/dev/md0 ro quiet splash 
Build Date: 20 April 2012  05:12:02AM
xorg-server 2:1.11.4-0ubuntu10.1 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.24.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 24 10:51:50 2012
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "xgi" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) Failed to load module "xgi" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 ddxSigGiveUp: Closing log
Server terminated with error (1). Closing log file.

So it appears to be wanting to use an xgi module for the display, but one is not found. lspci reveals that I do have an XGI on-board card:

root@murph:/etc/modprobe.d# lspci | grep VGA
01:03.0 VGA compatible controller: XGI Technology Inc. (eXtreme Graphics Innovation) Z7/Z9 (XG20 core)

Here is my /var/log/Xorg.0.log:

[130507.662] 
X.Org X Server 1.11.3
Release Date: 2011-12-16
[130507.662] X Protocol Version 11, Revision 0
[130507.662] Build Operating System: Linux 2.6.42-23-generic x86_64 Ubuntu
[130507.662] Current Operating System: Linux murph 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64
[130507.662] Kernel command line: root=/dev/md0 ro quiet splash 
[130507.662] Build Date: 20 April 2012  05:12:02AM
[130507.662] xorg-server 2:1.11.4-0ubuntu10.1 (For technical support please see http://www.ubuntu.com/support) 
[130507.662] Current version of pixman: 0.24.4
[130507.662]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[130507.662] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[130507.662] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 24 10:51:50 2012
[130507.663] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[130507.697] (==) No Layout section.  Using the first Screen section.
[130507.697] (==) No screen section available. Using defaults.
[130507.697] (**) |-->Screen "Default Screen Section" (0)
[130507.697] (**) |   |-->Monitor "<default monitor>"
[130507.698] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[130507.698] (==) Automatically adding devices
[130507.698] (==) Automatically enabling devices
[130507.698] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[130507.698]    Entry deleted from font path.
[130507.710] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
        built-ins
[130507.710] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[130507.710] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[130507.710] (II) Loader magic: 0x7f5268468b00
[130507.710] (II) Module ABI versions:
[130507.710]    X.Org ANSI C Emulation: 0.4
[130507.711]    X.Org Video Driver: 11.0
[130507.711]    X.Org XInput driver : 16.0
[130507.711]    X.Org Server Extension : 6.0
[130507.711] (--) PCI:*(0:1:3:0) 18ca:0020:1043:82b4 rev 0, Mem @ 0xf4000000/67108864, 0xfbdc0000/262144, I/O @ 0x0000ec00/128
[130507.711] (II) Open ACPI successful (/var/run/acpid.socket)
[130507.711] (II) LoadModule: "extmod"
[130507.788] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[130507.878] (II) Module extmod: vendor="X.Org Foundation"
[130507.878]    compiled for 1.11.3, module version = 1.0.0
[130507.878]    Module class: X.Org Server Extension
[130507.878]    ABI class: X.Org Server Extension, version 6.0
[130507.878] (II) Loading extension MIT-SCREEN-SAVER
[130507.878] (II) Loading extension XFree86-VidModeExtension
[130507.878] (II) Loading extension XFree86-DGA
[130507.900] (II) Loading extension DPMS
[130507.900] (II) Loading extension XVideo
[130507.900] (II) Loading extension XVideo-MotionCompensation
[130507.900] (II) Loading extension X-Resource
[130507.900] (II) LoadModule: "dbe"
[130507.900] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[130507.905] (II) Module dbe: vendor="X.Org Foundation"
[130507.906]    compiled for 1.11.3, module version = 1.0.0
[130507.906]    Module class: X.Org Server Extension
[130507.906]    ABI class: X.Org Server Extension, version 6.0
[130507.906] (II) Loading extension DOUBLE-BUFFER
[130507.906] (II) LoadModule: "glx"
[130507.906] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[130508.032] (II) Module glx: vendor="X.Org Foundation"
[130508.032]    compiled for 1.11.3, module version = 1.0.0
[130508.032]    ABI class: X.Org Server Extension, version 6.0
[130508.032] (==) AIGLX enabled
[130508.032] (II) Loading extension GLX
[130508.115] (II) LoadModule: "record"
[130508.115] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[130508.147] (II) Module record: vendor="X.Org Foundation"
[130508.147]    compiled for 1.11.3, module version = 1.13.0
[130508.147]    Module class: X.Org Server Extension
[130508.147]    ABI class: X.Org Server Extension, version 6.0
[130508.147] (II) Loading extension RECORD
[130508.147] (II) LoadModule: "dri"
[130508.147] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[130508.204] (II) Module dri: vendor="X.Org Foundation"
[130508.204]    compiled for 1.11.3, module version = 1.0.0
[130508.204]    ABI class: X.Org Server Extension, version 6.0
[130508.204] (II) Loading extension XFree86-DRI
[130508.204] (II) LoadModule: "dri2"
[130508.204] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[130508.219] (II) Module dri2: vendor="X.Org Foundation"
[130508.219]    compiled for 1.11.3, module version = 1.2.0
[130508.219]    ABI class: X.Org Server Extension, version 6.0
[130508.219] (II) Loading extension DRI2
[130508.219] (==) Matched xgi as autoconfigured driver 0
[130508.219] (==) Matched vesa as autoconfigured driver 1
[130508.219] (==) Matched fbdev as autoconfigured driver 2
[130508.219] (==) Assigned the driver to the xf86ConfigLayout
[130508.219] (II) LoadModule: "xgi"
[130508.219] (WW) Warning, couldn't open module xgi
[130508.219] (II) UnloadModule: "xgi"
[130508.219] (II) Unloading xgi
[130508.219] (EE) Failed to load module "xgi" (module does not exist, 0)
[130508.219] (II) LoadModule: "vesa"
[130508.219] (WW) Warning, couldn't open module vesa
[130508.219] (II) UnloadModule: "vesa"
[130508.219] (II) Unloading vesa
[130508.219] (EE) Failed to load module "vesa" (module does not exist, 0)
[130508.219] (II) LoadModule: "fbdev"
[130508.220] (WW) Warning, couldn't open module fbdev
[130508.220] (II) UnloadModule: "fbdev"
[130508.220] (II) Unloading fbdev
[130508.220] (EE) Failed to load module "fbdev" (module does not exist, 0)
[130508.220] (==) Matched xgi as autoconfigured driver 0
[130508.220] (==) Matched vesa as autoconfigured driver 1
[130508.220] (==) Matched fbdev as autoconfigured driver 2
[130508.220] (==) Assigned the driver to the xf86ConfigLayout
[130508.220] (II) LoadModule: "xgi"
[130508.220] (WW) Warning, couldn't open module xgi
[130508.220] (II) UnloadModule: "xgi"
[130508.220] (II) Unloading xgi
[130508.220] (EE) Failed to load module "xgi" (module does not exist, 0)
[130508.220] (II) LoadModule: "vesa"
[130508.220] (WW) Warning, couldn't open module vesa
[130508.220] (II) UnloadModule: "vesa"
[130508.220] (II) Unloading vesa
[130508.220] (EE) Failed to load module "vesa" (module does not exist, 0)
[130508.220] (II) LoadModule: "fbdev"
[130508.220] (WW) Warning, couldn't open module fbdev
[130508.220] (II) UnloadModule: "fbdev"
[130508.220] (II) Unloading fbdev
[130508.220] (EE) Failed to load module "fbdev" (module does not exist, 0)
[130508.220] (EE) No drivers available.
[130508.220] 
Fatal server error:
[130508.220] no screens found
[130508.220] 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[130508.220] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[130508.220] 

That's about the extent of my Xorg diagnostic skills - I'm comfortable around a commandline, but I've not had to mess with Xorg at all since the dark days of pre-ubuntu. i.e., not for many years.

Can anyone suggest what I do next?

Thanks!

share|improve this question
    
I'm encountering this exact issue after installing updates today as well. Ubuntu 12.04 on a Dell Optiplex 980, Intel Graphics (VGA and DisplayPort). Hoping for a solution soon... –  BHSPitMonkey Apr 27 '12 at 22:03
    
I dug around forever looking for a solution - the only viable option I could find is to buy a cheap pcie graphics card with a more fully supported chipset. This server is going to be decommissioned as a production box in the next week or so, at which point I'll install the cheapo graphics card I picked up with an nvidia chipset and see if that fixes things. –  Kimball May 3 '12 at 22:37
    
For what it's worth, I did a clean Ubuntu 12.04 install from CD over the old one and everything turned out fine. –  BHSPitMonkey May 10 '12 at 21:27
add comment

1 Answer 1

Make sure you have the xserver-xorg-video-sis package installed:

sudo apt-get install xserver-xorg-video-sis

Also make sure it is referenced correctly in /etc/X11/xorg.conf. I think it changed names from xgi to sis in 12.04. Eg, in /etc/X11/xorg.conf have:

Section "Device"
    Identifier      "XGI - Xabre Graphics Inc Volari Z7"
    Driver          "sis"
    BusID           "PCI:5:7:0"
EndSection

More details at my blog : http://www.excession.org.uk/blog/ubuntu-1204-and-xgi-graphics-cards.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.