Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I work in a library, so we have a Ricoh printer that is networked between all of us. I just recently installed Ubuntu 11.10 64bit on my desktop and have been trying to set up the printer without success. Ubuntu found the printer immediately and allowed me to set it up. When I hit test print, I get one sheet with writing on it and then it prints blank pages and will not stop until I turn off the printer. I tried printing from a document and I get the same one page with writing and then all the blank pages again. Below is what the page says with writing on it. I'd appreciate any help anyone is willing to give. Thanks.

%!PS-Adobe-3.0 %% %% mark () () (bunch of numbers) {setuserinfo} stopped cleartomark %%%!

share|improve this question
OK, I deleted the printer from the printers dialog box (I am using Gnome). I then readded the printer again, but I used this driver: epson-inkjet-printer-201109w_1.0.0. Now it works, but only when I plug in the usb cable. Any one have any ideas how to get the wireless part working? The wireless does work with my HP LaserJet P1102w printer. Thanks for all the help. Ed cohen – Edgar Cohen Feb 18 '14 at 21:34

Looks like you-re sending postscript directly to the printer, which may not understand it, that's why it spits blank pages.

Please double-check that you're using the correct driver for the printer; the driver is responsible for translating whatever applications send (most commonly, postscript) to something the printer can understand, so the behavior you describe suggests that you picked the wrong driver.

To see which driver you're using:

  1. Open the "Printing" control panel
  2. Right-click on your printer and select "Properties".
  3. On the first tab (Settings), look at "Make and Model".
  4. If you need to change it, press the "Change" button next to the field.
  5. Select your printer model (or something as close to it as possible) from the list.
  6. Test to see if it's working correctly.
share|improve this answer
Maybe this is part of the problem but I did not install any drivers for the printer. I simply found it in the list of networked printers and clicked on it and it loaded up and started printing. I went under drivers under settings but did not find anything for printer drivers nor did I see any under the Printer Settings. Where would I look to see if the driver is correct or not? – LibraryGeekAdam Apr 24 '12 at 14:54
Updated with instructions on how to verify the driver. – roadmr Apr 24 '12 at 15:06
I am also having the same printer problem. I dont find "updated with instructions.." by roadmr. Please let me know Where it is? – user78570 Jul 22 '12 at 10:53
@KS Nataranjan: Follow steps to "see which printer driver you're using", it's the list of numbers in my answer. I also suggest you open a new question with details on your particular problem. – roadmr Jul 22 '12 at 17:43

Most Ricoh's who also go by the name Nashuatec / Gestner / NRG / Probably others do not come with Postscript as standard it is an added extra on some models.

Roadmr is correct although I have had personal experience with this and you should be using the PXL driver as I show below. I know this is the case for the MPC 2000,3000,5000 and there many variants.

Ubuntu will automatically detect the printer but select Postscript, I have to after installing a printer go into the printer settings and manually choose a PXL driver as shown here.

  1. choose printers from the dash.

  2. right click on the printer and go to properties.

  3. choose change make and model.

  4. Select NRG -> MPC 2000 PXL

You should then be able to print and not waste a tree of paper.

enter image description here

share|improve this answer

The easiest thing to do is to manually add the printer by IP if it is networked something you can do is go to device and printers go to the actual printer right click go to printer properties and select the port table scroll down to the following IP which should be check copy it down go back to devices and printers add printer create a new port select standard TCP/IP enter the IP address which has been recorded next next and replace the current driver print a test page.

share|improve this answer

Our MPC 4000 works best with the foomatic driver, the plc6 driver from ricoh would do the 'spit all the paper out trick'. But the spooler/translator in foomatic works great.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.