Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.10 (dual booted with Windows Vista) but I'm unable to access internet wirelessly even though I can do so on Vista.

The output for rfkill list all is :

0: brcmwl-0: wireless LAN
         Soft blocked: no
         Hard blocked

The output for lshw -C network is:

  *-network               
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: eth0
       version: 03
       serial: 00:24:e8:c2:20:c9
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8168d-1.fw ip=192.168.0.104 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:46 ioport:3000(size=256) memory:f6004000-f6004fff memory:f6000000-f6003fff memory:f6020000-f603ffff
  *-network DISABLED
       description: Wireless interface
       product: BCM4312 802.11b/g LP-PHY
  • Broadcom STA wireless driver is installed, activated, and currently in use
  • My laptop is a Dell Vostro 1520
share|improve this question
    
Have you tried to see if there are proprietary drivers for it using 'additional drivers'? –  cprofitt Apr 24 '12 at 13:31
    
yes the Broadcom STA wireless driver is installed, activated and currently in use –  pmac95 Apr 24 '12 at 13:35
    
Can you update with make and model of your system? Thanks! –  roadmr Apr 24 '12 at 13:38
    
Are you seeing any wireless networks? –  cprofitt Apr 24 '12 at 13:40
    
Possible duplicate? - askubuntu.com/questions/33855/… –  jrg Apr 24 '12 at 13:51

1 Answer 1

up vote 3 down vote accepted

Could you try this command on a terminal?

sudo rmmod dell-laptop

If so, then you're affected by this bug, which is exactly on a Dell Vostro 1520:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/701259

A permanent workaround (try ONLY if the rmmod command does fix the problem) is to run this command on a terminal, to add the module to the blacklist so it doesn't load when the system boots:

echo "blacklist dell-laptop" |sudo tee -a /etc/modprobe.d/blacklist.conf
share|improve this answer
    
Thank you for that bug fixon my Dell vostro. Itś been a week and more of searching for solution to get my wireless working and this input from roadmr solve it to a tee(pun intended). Thank you everyone for all the support, you make having Ubuntu a joy, especially when things start acting up. merci beaucoup; tack so mycket :) –  pmac95 Apr 30 '12 at 11:37
    
Glad it worked. If you have a Launchpad.net account, I'd appreciate if you could access the bug I mentioned above and click on 'This bug affects 6 people. Does this bug affect you?". The more people are affected by it (and say so,), the higher the chance of it being looked at more actively. Thanks! –  roadmr Apr 30 '12 at 14:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.