Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How to disable the auto update dialog box shows every time while i am working? I have applied the following command yesterday but today still that is showing up. Is there any other way to permanently forever disable it?

$ gconftool -s --type bool /apps/update-notifier/auto_launch false
share|improve this question
add comment

3 Answers

up vote 8 down vote accepted

In the update manager, click the settings button in the bottom right. In the Updates tab of the resulting window, there are a number of options that control the behaviour of the update manager.

What is annoying you is that the When there are security updates: setting is set to Display Immediately. If you would like the protection of these security updates without being bothered, consider setting this to Download and install automatically instead.

With this change, the update manager will pop up at most once a week for the non-security updates. You can switch this to fortnightly by changing When there are other updates: to Display every two weeks.

There is also an option to turn off checking for updates entirely in this tab, but I would recommend against picking it since it can leave your system vulnerable to preventable problems.

share|improve this answer
2  
Can i also do this via command line? I have most of the time SSH access only. –  YumYumYum Apr 24 '12 at 10:03
2  
Changing the security updates section updates the /etc/apt/apt.conf.d/10periodic file, updating the APT::Periodic::Download-Upgradeable-Packages and APT::Periodic::Unattended-Upgrade settings. –  James Henstridge Apr 24 '12 at 10:19
add comment

I also find this annoying as I use the command line to update my system on my netbook. One way to silence it is to remove the package:

apt-get remove update-manager-core

It will also remove ubuntu-desktop and the janitor packages but in my case (Gnome3) it makes no difference to the base system I'm using. I suspect you could also remove the notifier from the start-up applications but that requires making them visible to you in the first place.

share|improve this answer
add comment

Ubuntu


Open Terminal. Type:

sudo sed -i "s/NoDisplay=true/NoDisplay=false/g" /etc/xdg/autostart/*.desktop
gnome-session-properties

When the "Startup Applications Preferences" window pops up, under "Additional startup programs:", scroll down to:

Update Notifier

Check for available updates automatically

On the left, disable the checkbox for "Update Notifier". Click "Close".

Source:

Lubuntu


Open LXTerminal. Type:

sudo sed -i "s/NoDisplay=true/NoDisplay=false/g" /etc/xdg/autostart/*.desktop
lxsession-edit

When the "Desktop Session Settings" window pops up, in the "Automatically Started Applications" tab, under "Applications automatically started after entering desktop:", scroll down to:

Update Notifier | Check for available updates automatically

On the left, disable the checkbox for "Update Notifier". Click "OK".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.