Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded to 12.04 from 11.10, and now I can't resolve custom domains over my VPN (e.g. *.dev.local). It worked splendid before the upgrade.

Both my /etc/resolv.conf and route -n looks exactly as it did before the update.

I am using OpenVPN and it connects without problem.

output from ping

$ ping
ping: unknown host


search office.local corp.local

route -n

# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 eth0   U     0      0        0 eth0 UG    0      0        0 tap0 UG    0      0        0 tap0 UGH   0      0        0 tap0 UGH   0      0        0 tap0 UG    0      0        0 tap0 UG    0      0        0 tap0 UG    0      0        0 tap0   UG    0      0        0 tap0   U     0      0        0 tap0

Snippet from /etc/dhcp3/dhclient.conf (22-25 is original before upgrade, previously had to remove domain-name-servers for some reason I've forgotten about)

 22 #request subnet-mask, broadcast-address, time-offset, routers,
 23 #       domain-name, domain-name-servers, domain-search, host-name,
 24 #       netbios-name-servers, netbios-scope, interface-mtu,
 25 #       rfc3442-classless-static-routes, ntp-servers;
 27 prepend domain-name-servers;
 28 request subnet-mask, broadcast-address, time-offset, routers,
 29         domain-name, domain-search, host-name,
 30         netbios-name-servers, netbios-scope, interface-mtu,
 31         rfc3442-classless-static-routes, ntp-servers;

Any help would be greatly appreciated.

Edit: I can reach the hosts by IP, it's just the resolving that does not work.

share|improve this question

Maybe look at /etc/nsswitch.conf. I had a problem with Ubuntu not acknowledging names from my local dns server regardless of the /etc/resolve.conf setting. Slackware worked fine so I modified mine to be a little closer to Slackware's version:

hosts:          files dns mdns4_minimal mdns4 [NOTFOUND=return]

I think I had to move the dns and mdns4 stuff... maybe there was an asterisk (*) that prevented further lookups.

share|improve this answer
Moving 'dns' before 'mdns' in this line resolved the issue for me on Ubuntu 14.10 (openconnect). – aemxdp Feb 12 '15 at 9:12

The problem is that the VPN uses local as its top-level domain which is also used by avahi for mdns.

Avahi's documentation


If you come across a network where .local is a unicast
DNS domain, please contact the local administrator
and ask him to move his DNS zone to a different domain.
If this is not possible, we recommend not to use Avahi
in such a network at all.
share|improve this answer

It is highly likely that when you are on VPN your nameserver and/or search domains are different. If you use nslookup for the custom DNS name you are trying to reach you'll need to see the nameserver that you are querying. If the address is different you are trying to resolve the name on a server where it is not listed.

for example...

munich:~ jeremy$ nslookup bangkok


Bangkok is a custom DNS name for a box in my home network. Were I to connect to my companies VPN I would hit their nameserver first so I can revolve their custom names such as svn and wiki. We have several namesevers at work, each with their own domain like and and If I have listed as my first domain and I try to reach with only svn the search will fail to resolve to an ip address because it will look for

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.