Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, for awhile I've been trying to get my external display to work. I'm running a Nvidia Geforce 305M graphics card in a Lenovo IdeaPad U460s. But when I open Nvidia X settings (Ubuntu 11.10 btw) a window pops up saying that I do not have the Nvidia X Driver installed and running and to run "nvidia-xconfig" (or whatever it says) as root, and then restart the X server. So I open the terminal and run command:

sudo nvidia-xconfig

Terminal does it's thing...and then I run this command (based on answers on THIS site):

sudo service lightdm restart

Then the Ubuntu Desktop/UI/blah blah blah shuts off, screen goes black and then white text appears on the screen like so:

*PulseAudio configured for per-user sessions
                                            saned disabled: edit /etc/default/saned
                                                     [OK]    *Starting anac(h)ronistic cron
                                                     [OK] *Stopping anac(h)cronistic cron
                                                     [OK] *Stopping cold plug devices
                                                     [OK] *Stopping log initial device creation
                                                     [OK] *Starting configure virtual network devices
                                                     [OK] *Starting configure network device security
                                                     [OK] *Stopping configure virtual network devices
                                                          *Checking battery state...
*Stopping System V runlevel compatibillity           [OK]

I have no idea what this screen is. I am capable of typing in it, though typed commands (terminal command lines) won't work (at least none that I've tried, but what do I know haha?)

Anyways...any help with this would be greatly appreciated, I am fairly new to Ubuntu and I love it so far, I would love it even more if I could get my peripheral hardware up and running (ie my Secondary Monitor)

share|improve this question
up vote 3 down vote accepted

Your IdeaPad appears to have switchable graphics; they're not well supported on Linux (yet). In fact, the proprietary nVidia drivers do not support Optimus systems at all, and the ‘Additional Drivers’ dialog should not offer to install them for you.

If your IdeaPad has an option in the BIOS to switch between the integrated and discrete GPUs then the nVidia drivers should work if that switch is set to discrete-only.

If you don't have a BIOS switch like that, then the nvidia drivers won't work, and trying to install them will make you unhappy.

The easiest way to recover would be to remove the configuration file telling X to load the nvidia driver; it will then autodetect what driver should be loaded, and load the Intel driver.

To do that, you want to run sudo rm /etc/X11/xorg.conf in a terminal.

If you've installed the nvidia drivers they will have broken the 3D component of the Intel drivers. To fix that, just remove the nvidia drivers (either through “Additional Drivers” or by running sudo apt-get remove nvidia-current).

share|improve this answer
how do I get to a terminal from this screen? and BTW, what is a TTY? – JimDean Apr 26 '12 at 5:11
A TTY is kernel-speak for a terminal - it's something that provides text input & output. I would reboot in recovery mode (hit <space> at the GRUB prompt, or after the BIOS screen if you don't have a GRUB prompt) to bring up the menu, and select the recovery mode option. – RAOF Apr 26 '12 at 23:23

you can run try to restart lightdm by entering this on the terminal... /etc/init.d/lightdm restart

I'm sure this will help and then run "dpkg-reconfigure nvidia" on the terminal.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.